ワークブック、ワークシート、列

Less grand image workbooks 650px.png

目次

ワークブック、ワークシート、列の基本

Originのワークブックはウィンドウの名前変更や移動、サイズ変更が可能で、データのインポートや整列、分析、変換、作図、表示のためのフレームワークを提供します。

ワークブックウィンドウでシート追加オーガナイザを表示/非表示の2つのボタンを利用できます。

Workbook buttons sheet organizer.png

ワークブック、ワークシート、列の制限

オブジェクト 最大数

ワークブックに含めるワークシート
1列のワークシートに入力可能な行数
5列のワークシートに入力可能な行数
32列のワークシートに入力可能な行数
1行のワークシートに入力可能な列数
100行のワークシートに入力可能な列数
1000行のワークシートに入力可能な列数

1024†
90,000,000
90,000,000
90,000,000
65,500
65,500
65,500

255シート以上の場合、Unicodeファイル形式 (例 *.opju) で保存する必要があります。Unicode対応のファイルは、Origin 2018より前のバージョンのOriginでは開けません。

ワークブック、ワークシート、列に名前を付ける


Workbooks 01C.png

ワークブック
  • ワークブックはショートネームと任意のロングネームコメントを持ちます。Origin内部のオペレーションにはショートネームが使用されます。
  • ショートネームは、プロジェクト内で固有で、スペースや特殊文字を含まず、文字(A-Z, a-z)で始まる最大13文字までに制限されています。
  • ワークブックロングネームは、必須ではありません。プロジェクトで固有である必要はなく、スペースや特殊文字を含めることができ、長さは最大5,506文字(半角)まで入力可能です。
  • ワークブックに名前を付けるには、ウィンドウのタイトルバーを右クリックして、プロパティを選びます。ここでロングネーム、ショートネーム、コメントを編集できます。「ウィンドウタイトル」ドロップダウンを使ってウィンドウタイトルバーにどちらの名前を表示するか制御できます。
ワークシート
  • ワークシートは名前ラベルコメントを持ちます。
  • 名前は、ワークブック内で固有である必要があります。
  • ワークシートの名前には、スペースを含めて最大64文字まで設定できます。特殊文字{}|"<>()![]は使用できません。
  • ワークシートのラベルコメントは任意です。プロジェクトファイル内で一意である必要はなく、任意の文字を任意の順序で使用でき、実用的な長さにすることができます。
  • ワークシートの名前を付けるには、シートタブでダブルクリックするか、タブを右クリックして表示するシート名を選択します。詳細は、以下のワークシートを参照してください。
  • 列はショートネームロングネーム(任意)を持ちます。
  • ショートネームは、ワークシート内で固有である必要があります。アイコンが表示され、スプレッドシートセル表記が有効な場合(デフォルト)、列ショートネームを編集できません(列ショートネームの制限を参照)。セル表記が無効になっている場合、列ショートネームを編集できます。列のショートネームは、特殊文字を含まず、文字(A-Z, a-z)または、数字で始まり18文字に制限されています。
  • ロングネームは、必須ではありません。プロジェクトで固有である必要はなく、スペースや特殊文字を含めることができ、長さは最大30,000文字(半角)まで入力可能です。ロングネームは、ロングネームセルをクリックするか列ヘッダを右クリックしてプロパティを選択して直接編集できます。
  • (1) ロングネームが存在している、 (2) ロングネームが利用可能な時はそれを使うチェックボックス(環境設定:オプション:その他のオプションタブ) を選択している場合に、選択したデータ範囲を参照するダイアログボックスとステータスバーは、ロングネームを表示します。そうでない場合は、ショートネームが使われます。

ワークブック

Originのワークブックは高度にカスタマイズ可能であり、データありワークブックファイルなど)またはデータなしワークブックテンプレートなど)の両方で保存できます。それらは多くの異なるアプリケーション用に構成できるため、時間の経過とともに多数のカスタムファイルを収集する可能性が高くなります。新しいブックダイアログは、使用するこれらのファイルを整理および選択するのに役立ちます。

新しいブックとブックテンプレート

New Book Dialog Controls.png

新しいブックダイアログを開くには

  1. ファイル:新規作成:ワークブック:参照をクリックするか、Ctrl + Nキーを押します。

新しいブックダイアログからテンプレートセンターを開くボタンTemplate Center Button.pngを利用できます。ボタンをクリックすると追加のワークブックテンプレートを参照でき、ダウンロードしてテンプレートリストに追加できます。


各ウィンドウプロパティダイアログにはテキスト入力のためのコメント欄があります。これらのコメントは、新規ブックダイアログのプレビューとプロジェクトエクスプローラのプレビューに含まれています。さらに、コメントは編集: プロジェクト内を検索ツールから検索できます。

スプレッドシートセル表記(SCN)

Originのワークブックではスプレッドシートセル表記:Spreadsheet Cell Notation (SCN)をサポートしています。SCNは表計算でよく知られているセルレベルの計算が可能です(詳しくはこちら)。

ワークブックに保存できるデータの種類

ワークブックは、テキストや数値データだけでなく、すべての作業関連データの保存場所として使用することもできます。グラフ、行列、画像、ノートを追加できます。また、計算式、スクリプトおよび変数、テキストオブジェクト、プログラムボタン等を保存したり、ほかのプロジェクトデータへのライブリンクを作成できます。柔軟なデータコンテナとしての役割を以外にも、ワークブックはバッチ分析レポートの媒体としても機能します。


UG workbook as container.png

ワークブック、ワークシート、およびワークシートのセルレベルでワークブックウィンドウに保存できるオブジェクトの種類と、それにアクセスする方法を表にまとめています。

要素 ワークブック ワークシート ワークシートセル
グラフ シートタブで右クリック > グラフをシートとして追加 ワークシート右側の灰色の領域で右クリック > グラフを追加 セル上で右クリック > グラフを挿入
行列 シートタブを右クリック > シートとして行列を追加 -- --
イメージ -- -- セル上で右クリック > ファイルからイメージを挿入

下記参照

 

ノート ワークブックのタイトルバーで右クリック > プロパティ > コメント ワークブックのオーガナイザを表示/非表示ボタンをクリック > データシート > ボックス内にノート入力 セルをクリックしてミニツールバーのノートを挿入 (下記参照)
変数 ワークブックのオーガナイザを表示/非表示ボタンをクリック > page.info, Imported Files, User Treeなど データ/変数にリンクしたテキストオブジェクトを追加 ワークシートセルで右クリックして変数の挿入、または、セルを選択してミニツールバーの名前を定義をクリックします。
関数と式 ワークシート右側の灰色の領域で右クリック > スクリプトパネルを表示 列を選択して右クリックして列値の設定を選択します。あるいは、F(x)=セルに式を入力します。 セルをクリックして数式バーを使用または直接セルに入力してセル式を作成します。
スクリプト ワークシート右側の灰色の領域で右クリック > スクリプトパネルを表示 --
ファイルのメタデータ ワークブックツールバーのオーガナイザを表示/非表示ボタンをクリック -- --
リンク -- -- URL、他のワークシート範囲/セル、プロジェクト内のグラフ、行列、画像ファイルへのセルレベルのリンクを入力します。

下記参照

 

テキストおよび描画オブジェクト -- プログラム可能なボタンテキストラベルおよび描画オブジェクトをワークシートに追加します。 --
矢印 -- -- 右クリックして矢印の挿入

Origin 2023では、ファイルから画像を挿入 (nsertimg) ダイアログで挿入方向項目(水平方向優先または垂直方向優先から選択)が追加され、複数ファイルをアクティブワークブックに挿入する際に便利です。:UG insert image direction horizontal.png

 

Origin 2023でハイパーリンクセルテキストの取り扱いが改良されました。

  • リンクセルをALTキーを押しながらダブルクリックすることで、既存のハイパーリンクテキストの編集が可能です。以前のバージョンでは、リンク編集前に編集:編集モードを選択する必要があります。
  • ハイパーリンクセルのテキストフォーマットの変更や整列が可能です。ワークシートのラベル行とデータ行の両方でサポートされています。
UG format linked text worksheet.png

 

ワークシート

ワークブックは、最大1,024個のシートを持つことができます。シートは1つの名前をもち、これはスペースや特殊文字を含めることができます。オプションで、ラベルコメントを追加できます。

シート名を編集する方法

  1. シートタブをダブルクリックして名前を入力します。あるいは、シートタブを右クリックして名前とコメントを選択し、名前を編集します。


システム変数@SSLでシートの命名動作を変更できます。LabTalkシステム変数リストの@SSLを参照してください。

ワークシートタブにマウスカーソルを合わせると、ツールチップとしてワークシートの名前ラベルコメントが表示されます。


ワークブックにシートを追加するには、ワークシートタブ上で右クリックして以下のいずれかを選択します。

ワークブックの各シートはカスタマイズ可能です。ワークシートを挿入または追加した場合、新しいシートはORIGIN.otwuファイルを元に作成されます。 (ORIGIN.otwuを編集している場合には、ユーザファイルフォルダに保存されています。)列の数やフォーマットをカスタマイズしたほかのシートを元に新しいシートを追加するには、複製またはデータなしで複製メニューコマンドを使用します。


シートを既存のブック間で移動する場合、または、シート移動して新しいブックにするには

(A) 既存のブック間でシートをドラッグまたは、 (b) シートをOriginのワークスペース内の空の部分にドラッグ&ドロップして新しくブックを作成します。

UG drag sheets to new book.png

Origin 2023では、ブック間でドラッグするときやワークスペースにドラッグ&ドロップする際に、複数シートを選択して一括で移動することができます。

  1. Shift/Ctrlキーを押しながら複数ワークシートをクリックして他のウィンドウにドラッグするか、ワークスペースの空の領域にドラッグします。

または、

  1. ワークシートタブで右クリックして、移動を選びます。ワークシートの操作ダイアログで、Ctrl/Shift キーを押しながらシートを選択して右クリックし、移動先新規ブックまたは選択済みブックを選択します。

 

ワークシートプロパティ

ワークシートのプロパティダイアログを開く

  1. ワークシートの右側にある灰色の領域(ワークブックの内側)を右クリックして、ワークシートの表示属性を選びます。


ワークシートプロパティダイアログボックスは次のようなシートのプロパティをカスタマイズできます。


シートの設定のほとんどは、セルを選択して右クリックしてセルのフォーマットを選択すると、セルレベルでも適用できます。

詳細情報は、ワークシートプロパティダイアログを参照してください。

  • Origin 2023より前のバージョンでは、ワークシートセルのリッチテキストテキストの折り返しを同時に有効にできません (ワークシートプロパティダイアログでリッチテキストではテキスト折り返しができないという警告が表示されます)。現在では、リッチ テキスト対応のセルに長いテキスト文字列を入力でき、編集モードを終了すると、テキストが自動的に折り返されます (セルの内容全体を表示するには、セルのサイズ変更が必要になる場合があります)。
  • 行を選択し、ラベル行のミニツールバーのテキストの折り返しボタンをクリックすると、列ラベル行のテキストの折り返しのオン/オフを切り替えることができます。
UG wrap text toggle label row.png

 

Origin 2023でワークシート行を縞模様に配色するミニツールバーボタンが追加されました。

UG MT worksheet banded rows.png
  1. ワークシート列の右上にマウスカーソルを移動させて、カーソルの表示が変更したらクリックしてシートレベルのミニツールバーを表示します。
  2. 縞模様(行)ボタンをクリックすると、(a) 行が縞模様の配色になり、(b)ミニツールバーに縞模様(行)の色ボタンが追加されます。
  3. 縞模様(行)の色ボタンをクリックするとダイアログが開き、配色を変更できます。

 

オブジェクトマネージャでシートを操作

オブジェクトマネージャのショートカットメニューを使ってワークブック内容の表示を操作できます。


UG UI OM workbook.png
シートの非表示/表示

Origin 2023から、ワークシートを非表示(表示)が可能になりました。これは、オブジェクトマネージャで操作できます。

 

  1. オブジェクトマネージャで、1つ以上のシートを選択します。
  2. 右クリックして隠すを選択します。オブジェクトマネージャで非表示シートが淡色表示になり、ワークブックで非表示になります。
  3. シートを表示するには、淡色のシート名を右クリックして表示を選択します。
UG OM hide sheets.png
  1. ワークシート右側の灰色の領域で右クリックして、オーガナイザを表示を選択します。
  2. 左下のパネルで、非表示のシートは淡色表示されます。この淡色表示のシートをダブルクリックすると表示できます。
UG show hidden sheets organizer.png

ワークシートの表示: 分割と固定

ワークシートの一部分を固定して、残りの部分だけをスクロールすることができます。状況に応じて2通りの方法を使用できます。

ディバイダを使ってワークシートを複数パネルに分割

選択した行または列に移動可能な垂直または水平のディバイダを配置できます。または、単一のセルが選択されている場合は、垂直方向と水平方向の両方のディバイダとして使用できます。これにより、ワークシートがデータ領域の同一のスクロール可能なビューに分割されます。他のパネルの行または列を表示したまま、各パネル内をスクロールできます。

UG window split.png
  1. ワークシートの行/列または単一セルを選択してウィンドウ:ウィンドウ分割を選択します。
  2. ウィンドウ:分割を削除を選択してディバイダを削除できます。


ワークシートの行または列を固定

Origin 2023の新機能です。

 

ワークシートの最初の1~10行または列を固定して、残りの行または列をスクロールすることができます。固定された行および列はヘッダは、固定されていることを示すために位色で表示されます。

UG frozen rows cols.png
  1. 行または列、あるいは行/列番号 = 1~10にある単一のセルを選択して、以下のいずれかの操作をします。
UG MT freeze unfreeze.png

ワークシート列


列名は次の方法で変更できます。


ワークシート列の命名規則は上の表をご確認ください。

列のXY属性

前述のように、ワークシートの列のXY属性(別名「プロット属性」)は、通常、分析および作図の操作中にデータがどのように処理されるかを決定します。たとえば、X列+ 3つのY列を選択して、X値の共通セットに対して各Yデータセットの同時線形フィットを実行できます。または、同じ列を選択して、共通のX値のセットに対して3本の線のプロットをグラフ化することもできます。さらに、Z値、エラーデータ、ラベルなどの指定があります(詳細については、Originヘルプファイルの列属性を参照してください)。

Designation symbols.png


ユーザインターフェイスには、分析や作図の操作中に列を指定できる場所がいくつかありますが、基本的なレベルでは、(1)列ヘッダをクリックして列を選択し、次に列ヘッダをクリックしてワークシートに設定します。 (2)次のいずれかを実行します。

列プロパティダイアログボックス

列プロパティダイアログボックスは次のような列のプロパティをカスタム化できます。


「列プロパティ」ダイアログボックスを開くには:

  1. 列ヘッダをダブルクリックします。
  2. 選択した列を右クリックして、列フォーマットを選択します。

ショートネームプロパティタブで編集できます。その他のプロパティ(ロングネーム単位コメントなど)もここで編集するか、列ラベル行に直接入力します。

列データのフォーマット設定

Originのワークシートのデータはテキストまたは数値データのどちらかとして扱われます。ワークシート内のテキストデータの表示は簡単ですが、数値データの表示はより複雑です。

特に指定しない限り、ワークシート内のすべての数値は、内部的に浮動小数点、倍精度(Double(8))の数値として格納されます。これには、日付と時刻、桁単位で表示するようにフォーマットされたデータ、または固定小数点数を表示するようにフォーマットされたデータが含まれます。

数値データを扱うときは、ワークシートに表示されている内容が、内部的に格納されている数値を(ワークシートの設定によって)表現したものであることに注意してください。この点は2つの理由から重要です:

ワークシートデータをフォーマットするための中心的な場所は、上記のようにプロパティダイアログですが、数値データと日時データの表示を変更するためのクイックアクセスミニツールバーボタンがあることに注意してください。これらのボタンを表示するには、最初に選択した列のフォーマット日付または数値/文字と数値に設定する必要があることに注意してください。

UG MT Numeric Format Buttons.png


数値表示フォーマット
  1. 列ヘッダをダブルクリックして列プロパティダイアログを開きます。
  2. プロパティタブをクリックし、フォーマット = 数値と設定します。
  3. 表示十進数: 1000指数: 1E3工学: 1K十進数: 1,000またはカスタムのいずれかに設定します(詳細は以下)。


日付と時間のフォーマット

デフォルトでは、Originは日時データをユリウス暦の値として保存し、日時の計算にこの数値を使用します。ただし、通常は、このユリウス歴の値をより意味のある日時形式で表示することをお勧めします:

  1. 列ヘッダをダブルクリックして列プロパティダイアログを開きます。
  2. プロパティタブをクリックし、フォーマット時間日付または曜日のいずれかに設定します。
  3. 表示リストのオプションからいずれかを選択します。
  4. リストのオプションのどれも適さない場合にはカスタム表示を選択し、これらの日付ー時間のフォーマット指定子を作成します。

日時データをワークシートにインポートするとき、Originはこのデータをテキストとして認識することがあります(OriginのCSVコネクタは通常、日時データをうまく認識することができます)。日付ー時間データがワークシートのセル内で左揃えになっている場合、Originはそれをテキストと認識しています。この場合、列プロパティダイアログボックスを開いて適切なフォーマット表示のオプションを選択する必要があります。日付ー時間データがセル内で右揃えになっている場合、Originはそれを数値と認識し、日付ー時間形式で表示します。

Workbooks formatting data1.png
カラーフォーマット

Origin 2021では、まったく新しい列とセルのフォーマット-が利用できます。

UG Cell Color Format.png
UG Color List From Column.png
その他のカスタム表示フォーマット

Originは、さまざまなカスタム形式で数値をワークシートに表示できます。この図は、同じ数値セットに適用されるさまざまなフォーマットを示しています(列A(X))。

ColProperties Custom Formats.png

以下は、サポートされているカスタムフォーマットオプションのサンプルリストです(Origin 2019に組み込まれている事前入力済みのリストです)。カスタム表示は、カスタム表示リストに直接入力することができ、それらはこのリストに保存されます。

他にも多くのフォーマットオプションがあります。詳細は、カスタム数値フォーマットを参照してください。

Origin 2023では、カスタム表示の際に正負の符号 (+/-) を表示可能になりました。例えば、正と負の両方の数値を含む列がある場合、カスタム表示を「-+.2」に設定することで、「-」または「+」の接頭辞を付けて小数点以下 2桁まで数値を表示できます。 通常は、「-」は表示しますが、「+」は表示されません。ただし、この構文は、ワークシートの負の数値の表示に使用される通常の「短いマイナス」のでなく「長いマイナス」を使用します。「-」と「+」記号は、「-+」などのようにカスタム文字列で組み合わせて使用​​することも、「-」などのように単独で使用することもできます。

UG custom display plus minus.png

 

表示フォーマット 説明 例:
セルの値 = 123.456の場合
*n n桁の有効桁数を表示します。 *3123と表示します。
.n n 桁の小数桁数を表示します。 .4123.4560と表示します。
S.n 科学的表記1E3n桁の小数桁数を表示します。 S.41.23456E+02と表示します。
E.n 工学表記でn 桁の小数桁数を表示します。 E.2123.46と表示します。
* "pi" 数字を10進数で表示し、その後に記号πを表示します。 * "pi"39.29727πと表示します。
#/4 "pi" 分母を"4"とし、πの小数部として数値を表示します。 #/4 "pi"157π/4と表示します。
#/# "pi" 数字をπの小数部として表示します。 #/# "pi"275π/7と表示します。
##+## 数字を1桁、"+"区切り記号、2桁の数字(例:測量ステーション)として表示します。 ##+##01+23と表示します。
#+##M 数字を1桁、"+"区切り記号、2桁の数字、および"M"を接尾辞として表示します。 #+##M1+23Mと表示します。
#n 数字をn桁の整数で表示し、必要に応じて先頭にゼロを付加します。 #500123と表示します。
#% 数字をパーセンテージで表示します。 #%12346%と表示します。
# ##/## 数字を適切な割合で表示します。 # ##/##123 26/57と表示します。
# #/n 数字を適切な割合でn番目に表示します。 # #/8123 4/8と表示します。
DMS 1度 = 60分、1分 = 60秒として、数字を度° 分’ 秒"の形式で表示します。 DMS123°27&apos;22"と表示します。
D MDn EW (経度)
D MDn NS (緯度)
度数と小数点以下の桁数で数字を表示します。パラメータnは小数点桁数を指定します。正の値には "E"または "N"が付加され、負の値には "W"または "S"が付加されます。負の値を保持したい場合は、 "EW"または "NS"を付加しないでください。 D MD3 EW123° 27.360 Eと表示します。
D MDn EWB (経度)
D MDn NSB (緯度)
度数と小数点以下の桁数で数字を表示します。パラメータnは小数点桁数を指定します。文字"B" ("before") は、正の値に"E"または"N"が前置され、負の値に"W" または"S"が前置されることを指定します。負の値を保持したい場合は、 "EWB"または "NSB"を追加しないでください。 D MD3 EWBE 123° 27.360と表示します。
 %#x 数字を32ビットの16進数(最大8桁)で表示します。"#"記号は "0x"接頭辞を指定します。 %#x0x7bと表示します。
 %#0nx n文字の文字列として数字を32ビットの16進数(最大8桁)の表記法で表示し、必要に応じて先頭に0を付けます。 %#06x0x007bと表示します。
 %#0nI64X n文字の文字列として数字を64ビットの16進数(最大13桁、#= "0x"を含む15の合計)の表記法で表示し、必要に応じて先頭に0を付けます。 %#014I64X0X00000000007Bと表示します。

列ラベル行

列ラベル行には、メタデータ(他のデータを説明するためのデータ)が保存されます。一般に、このメタデータは、インポートされたファイルのヘッダ情報として取り込むことも、手動で入力することもできます。列ラベル行の表示は任意で、必要に応じてユーザーは選択的に表示または非表示にできます。

列ラベル行情報は、作図の操作で(たとえば、ワークシートロングネームはグラフ凡例または軸タイトルのテキストとして)頻繁に使用されます。F(x)= 行は、データの列における数学演算を実行する際に使用されます(下記参照)。ユーザパラメータ行に格納されたデータは、プロット、データ操作、統計解析、または数学演算におけるデータセットのラベル付けまたはグループ化などで使用されます(チュートリアル2参照)。

align="center"

ワークシートの部分範囲を選択してコピー貼り付けの操作をする際、ラベル行を含めることができます。ラベル行を含めてデータセルをコピーするには、選択した部分範囲を右クリックして、コピー(ラベル行を含む)を選択します。

Origin 2023では、ステータスバーに選択したラベル行の統計値を表示できます。

 

UG label row stats.png

列ラベル行の表示設定

列ラベル行の表示(表示または非表示)は、ショートカットメニューコマンドで制御できます。

Workbooks 03B.png
  1. 右クリックして、ショートカットメニューから表示を選びます。
  2. 右クリックして列ラベル行を編集を選択するか、他のラベル行のコマンドを選択します。
  3. 右クリックしてワークシート要素のコントロール(行ラベルや列ヘッダの表示など)、あるいは、この領域のセルを選択後右クリックしてコメントの書式を設定可能です。

ラベル行を管理するためのワークシート列ラベル行ミニツールバーもあります。選択したラベル行の非表示、リッチテキストの有効化、ラベル行の順序を変更などを行う「ために使用します。

UG MT worksheet label row.png

列リストビュー

Origin 2019では、列ラベル行メタデータの転置ビューである列リストビューと呼ばれるワークシートの新しい表示モードが導入されました。このビューは、ワークシートに多数のメタデータ行があり、そのメタデータの特定の側面に注目したい場合に便利です。ワークシートをアクティブにして、表示: 列リストビューを選択するかCTRL + Wを押します。

Workbook Column List View 1.png

列リストビューのメタデータにデータフィルタを適用することができます。標準のワークシートビューに戻ると(表示:列リストビューの横のマークをオフにすると)、フィルタ処理されたメタデータに関連付けられているデータのみがワークシートに表示されます。

列リストビューは列ショートネーム(+列属性)の前に列番号を表示します。さらに、列ロングネームの左端にマウスカーソルを合わせると、ツールチップにデータセットサイズが表示されます。列番号の表示を無効にするには、@DSI=1に設定します。

UG CLV index.png

スパークライン

列に入力された数値データは、スパークラインというラベル行にグラフィカルに表示されます。 スパークラインはその列内のデータの小さなインセットグラフで、これは行番号を独立変数(X)、列内数値を従属変数(Y)としてプロットしたものです。50列より少ないデータをインポートすると、デフォルトでスパークラインが表示されます。

Sparklines column label row.png


スパークラインの表示と非表示

Sparklines histogram box.png

スパークラインが大量にあると、Origin の動作が遅くなる可能性があります。プロジェクトの動作が遅い原因がスパークラインの表示である可能性がある場合、システム変数@SPKを使用してスパークラインの作成を止め、プロジェクト内の既存のスパークラインを非表示にできます。また、delete -spkで現在のプロジェクトからスパークラインを削減可能です。

ワークブックオーガナイザ

前述したように、ワークブックにはメタデータが保存され、その一部は列ラベルの行に表示されます。ほかのメタデータはワークブック内で非表示になっています。非表示のメタデータには、インポートファイルのパス、名前、データをインポートした日付と時間、ヘッダ情報、様々な名前や変数等のメタデータ等が含まれます。これらの非表示のメタデータは、ワークブックオーガナイザで表示できます。

ワークブックのオーガナイザパネルを表示/非表示にする


Workbook organizer.png

ミニツールバーによるワークブックの設定

ブック、シート、列およびセルレベルのプロパティの多くは、ミニツールバーのボタンで設定することまたはオン/オフを切り替えることができます。

MT worksheet column selected.png

Origin 2023では、ミニツールバーボタンを使用して、選択した1つまたは複数のワークシート行を上下に移動できます。

UG MT move worksheet rows buttons.png

いくつか制限事項があります。

  • データ コネクタを使用してデータをインポートした場合は、行を移動する前に、緑色のコネクタアイコンDC Icon Live.pngをクリックし、インポートしたデータのロック解除を選択する必要があります。
  • 再計算が有効になっている分析レポートシートでは、行を移動できません。

 

ワークシートの検索と置換

MT Find Button.png

Big Find.png

Originには、スクリプトでできるもう1つの置換ツールであるwreplaceがあります。ダイアログを開く場合は、スクリプトウィンドウ(ウィンドウ:スクリプトウィンドウ)を開き、wreplace -dを入力して実行します。スクリプトのオプションなど詳細は、wreplaceのXファンクション文書を参照してください。

列に数値を入力するシンプルな方法

Origin 2023の新しいデータ選択の方法

  • ワークシートデータの範囲を選択するとき、Ctrlキー+クリックまたは、Ctrlキー+ドラッグで不要なセルの選択を解除します。
  • 列を選択して Ctrl + Shift + 右矢印を押すと、最後の入力のある列まで選択範囲が拡張されます。行を選択して Ctrl + Shift + 下向き矢印を押すと、最後の入力のある行まで選択範囲が拡張されます。

 

Originは、ワークシートのある範囲や、ワークシート列に数値を入力するための機能をいくつか提供しています。最も簡単な方法は、メニューコマンドを使って列に行番号一様乱数正規乱数を入力する方法です。これはOriginの機能を素早く確認するためのデータを用意する際に便利です。

事前選択したワークシートや列にデータセットを生成する操作は以下の通りです。

アクション ツールバーボタン メニューコマンド
範囲または列に行番号を入力 Button Set Col Values Index.png
  • 列:列値の一律設定:行番号

または

  • 列を右クリックし、列値の一律設定:行番号を選択
0から1までの範囲で一様に分布した乱数を列に入力 Button Set Col Values Uniform Random.png
  • 列:列値の一律設定:一様乱数

または

  • 列を右クリックし、値の一律設定:一様乱数を選択
一様に正規分布乱数を列に入力 Button Set Col Values Normal Random.png
  • 列:列値の一律設定:正規乱数

または

  • 列を右クリックし、値の一律設定:正規乱数を選択
パターン化された、あるいは、ランダムな数値のセットを列に入力 --
  • 列を右クリックし、列値の一律設定:数値セットを選択
パターン化された、あるいは、ランダムな日時のセットを列に入力 --
  • 列を右クリックし、列値の一律設定:日付/時間の値のセットを選択
テキストと数値のセットを列に入力 --
  • 列を右クリックし、列値の一律設定:テキストと数値の任意のセットを選択


オートフィル機能は、列ラベルの行やワークシートデータ部分のセルで使用することができます。

オートフィル機能を使って拡張パターンを入力する(数値データのみ)には、

  1. 連続するセルブロックを選択し、マウスカーソルを選択範囲の右下隅に移動します。
  2. 選択領域の右下角にマウスを移動し、カーソルが、+の形状になったらALTキーを押しながら、下方向または右方向の入力したいセルにドラッグします。


オートフィル機能を使って繰り返しパターンを入力する(テキストまたは数値データ)には、

  1. 連続するセルブロックを選択し、カーソルを選択範囲の右下隅に移動します。
  2. 選択領域の右下角にマウスを移動し、カーソルが、+の形状になったら、CTRLキーを押しながら、下方向または右方向の入力したいセルにドラッグします。


LabTalkスクリプトを使用してすばやくデータセットを生成することもできます。例:

  1. 新規ワークシートを作成し、ウィンドウメニューのスクリプトウィンドウを選択して開きます。以下のスクリプトコードをコピーして貼り付けます。
  2. col(1)={0:0.01:4*pi};
    col(2)=sin(col(1));
    	
  3. これらを選択状態にしてEnterキーを押して実行します。ワークシートの最初の2列にデータが入力されます。

列値の設定

最近のバージョンでは、Originの組み込み関数にアクセスしやすくなりました。

  • 値の設定ダイアログおよびF(x)=セルで自動補間機能をサポートしました。入力を始めると利用可能な関数のリストが表示されます。
  • 値の設定ダイアログの関数メニューから開ける関数の検索ダイアログが、メインメニューのツール:関数の検索を選択することで直接開けるようになりました。

オートコンプリートヒントの機能がOrigin 2023で改良され、関数のすべての引数が入力されるまでヒントが表示されたままになります。これは、値の設定ダイアログ、F(x)=ラベル行、およびセルの数式に適用されます。

 

値の設定ダイアログでは、一つ以上のワークシートデータ列へのデータ作成、またはデータの変換を行うことができます。このダイアログボックスには、メニューバー、出力範囲の定義に使用するコントロール、LabTalk関数を検索して式に挿入するツール、1行の数式を定義する列式ボックス、データの前処理や列式で使用される変数の定義を意図した 実行前の処理スクリプトパネル(任意で使用)、および Pythonユーザーの場合、式で使用できるPython関数を定義および使用するためのPython関数タブが含まれています。

SetValues.png

Origin 2017から、値の設定にある計算式のボックス(上部のボックス)は、MS ExcelとGoogleシートのようなスプレッドシートセル表記をサポートしています。セルはショートネーム+行インデックス番号の使用して位置を指定できます(例えば、列Aの第一セルは以前は"col(A)[1]"でしたが、"A1"で示されます)。

新しいワークブックでは、スプレッドシートセル表記はデフォルトで有効になっています。スプレッドシートセル表記は、列の計算式を定義する場合のみ利用できます。これは、列値の設定の実行前の処理スクリプトパネルでもLabTalkスクリプトでも利用できません。「以前」の列およびセル表記は「スプレッドシート」モードでも機能するので、以前の表記法に慣れていてこれを使いたい場合は、いつでも入力できます。スプレッドシートセル表記や以前の方法については、列式のサンプルを参照してください。

単一列の値の設定ダイアログボックスを開くには:

  1. ワークシート列を選択するか、ワークシート列のセルの範囲を選択します。
  2. メニューから、列:列値の設定を選択するか、選択した列で右クリックして、ショートカットメニューから列値の設定を選びます。


複数列の値の設定ダイアログボックスを開くには:

  1. 連続した複数のワークシート列を選択するか、ワークシート全体を選択します。
  2. メニューから、列:複数列値の設定を選択するか、選択した列で右クリックして、ショートカットメニューから複数列の値を設定を選びます。
SetValues Multiple.png

値の設定メニューコマンド

メニューコマンド
  • 計算式:計算式入力ボックスに、保存した計算式の情報をロードします。計算式の保存は、計算式:保存または計算式:名前を付けて保存を使用します。
  • wcol(1):計算式内や、実行前の処理スクリプトにワークシート列を含めるときに使用します。列ブラウザを使用して的確に列を選択することもできます。列は、列インデックス別によって一覧表示されます。
  • Col(A):wcol(1)メニューの似ていますが、列名を使用したリストが表示されます。
  • 関数: OriginのLabTalk関数を挿入するために使用します(カーソルの場所に関数が挿入されます)。メニュー リストの関数にカーソルを合わせると、関数の説明がステータスバーに表示されます。関数を選択すると、その説明がポップアップのスマートヒントに表示されます。
  • 変数: 計算式実行前の処理スクリプトに変数、定数、範囲変数(選択も可能)やファイルのメタデータを挿入します。
  • オプション:ワークシートの数式行で計算式の直接編集を可能にし、式についてのコメントを追加や、値が設定された列のテキストを保存(テキストを欠損値として扱わない)保持するなどのオプションを利用できます。
列の数式
  • データを生成する1行の式を追加します。関数、条件演算子、および変数を使用できます。
実行前の処理スクリプト
  • 列の式ボックスの式が実行される前に実行されるLabTalkスクリプトを入力します。
Python関数

値の設定ダイアログの関数メニューに表示される、関数の上にマウスカーソルに移動すると、ステータスバーに関数の概要が表示されます。関数を選択すると、より詳細な説明と完全な関数の説明、構文、サンプルなどへのリンクを含むスマート ヒントが表示されます。

また、関数の検索と挿入ボタンSearch Insert Functions.pngをクリックすると、キーワードで利用可能な関数を検索して挿入できます。


詳細は、列値の設定 - クイックスタートを参照してください。

「F(X)=」ワークシート列ラベル行

簡単な式であれば、F(x)= 行に列の値を設定できます。ここで入力した数式は、値の設定ダイアログに直接入力されます。値の設定の計算式で使用できたスプレッドシートセル表記は、F(x)=でも使用できます。

  1. F(x)=列ラベル行のセルをダブルクリックします。
  2. 式を入力して、データ列に結果を出力します。
Fx column label row.png

Origin 2023F(x)=ラベル行の使いやすさの改善

  • オートコンプリートヒントの機能がOrigin 2023で改良され、関数のすべての引数が入力されるまでヒントが表示されたままになります。これは、値の設定ダイアログ、F(x)=ラベル行、およびセルの数式に適用されます。自動補間機能を非表示にしたい場合は、システム変数@FAC=0を設定すると無効にできます。
  • 列の式の自動入力がサポートされるようになりました。以前は、列の式を右にドラッグすると、同じ式が他のF(x)=セルにコピーされるだけでした。現在は、一連の新しい入力データセットを使用するした数式が自動入力されます。使用するには、セルの右下隅にカーソルを置き、カーソルが 「+」の表示になったら、Ctrl キーを押しながらマウスで右にドラッグします。

 

UG autofill column formula CTRL.png

列値の設定チュートリアル

チュートリアル1:F(x)= を使った単位変換

  1. 新しいワークブックを開き、\Samples\Graphing\WIND.DATをインポートします。
  2. B列にあるSpeedの値が、マイル/時(MPH)の単位で入力されているとします。列Cの列ヘッダを選択してから、右クリックしてから挿入を選択します。新規に列Cを挿入し、 Powerの値を列Dに移動します。
  3. 列BにあるMPHの値をkm/時(KPH)の単位に変更します。列CのF(x)=セルでダブルクリックして以下のように入力します。
    B*1.6
    			
    そして、ENTERキーを押します。列Cの値の単位は、KPHになります。


チュートリアル2:移動平均と移動標準偏差を算出する

  1. Samples\Signal Processing\fftfilter1.DATファイルをインポートします。
  2. Button Add New Columns.pngを二回クリックして、ワークシートに2列追加します。
  3. 3番目の列のヘッダをクリックし、右クリックして開くコンテキストメニューから、列値の設定を選択します。
  4. 値の設定ダイアログが開いたら、上部パネルに以下を入力します。
    movavg(B,5,5)
    			
    適用ボタンをクリックします。列3には、2列目のデータに対する11ポイントの移動平均の値が入力されます。(movavg のような関数は、値の設定ダイアログの関数メニューから挿入できます)
  5. >>ボタンをクリックして、4列目の編集ボックスに切り替えます。
  6. 4番目の列の編集ボックスで、以下の式を入力します。
    movrms(B,5,5)
    			
    OKボタンをクリックします。これにより、4列目には、各点で11のウィンドウサイズを使用した平均平方の平方根(RMS)の値が入力されます。


チュートリアル3:複数列の値を同時に設定する

  1. 標準ツールバーの新規プロジェクトボタンButton New Project.pngをクリックして、新しいプロジェクトを作成します。
  2. 複数ASCIIのインポートボタンButton Import Multiple ASCII.pngをクリックして、<Origin フォルダ>\Samples\Import and Export\ のパスにあるF1.datとF2.datをインポートします。impASCダイアログで、複数ファイル(第一以外)インポートモードブックを新たに作って読み込むにしてOKをクリックします。
  3. 2つのワークブック、F1とF2が作成されます。標準ツールバーの新規ワークブックボタン New Workbook.pngをクリックし、新しいワークブックを作成します。
  4. 3番目のワークブックがアクティブな状態で、列の追加ボタン Button Add New Columns.pngをクリックします。全ての列を選択し、列:複数列の値を設定とメインメニューから操作するか、右クリックして複数列の値を設定をショートカットメニューから選択して値の設定ダイアログを開きます。
  5. スクリプトを表示ボタンButton Show Scripts.pngをクリックして下部パネルを拡張します。次のスクリプトを実行前の処理スクリプト編集ボックスに入力します。
range r1=[F1]F1!wcol(j); //"j" is the column index.
range r2=[F2]F2!wcol(j);
		
  1. 列の式編集ボックスに(r1+r2)/2 と入力します。
  2. オプション:式セルを直接編集の項目のチェックを外します。
  3. オプション:式テキストと選択して、式テキストダイアログに(F1+F2)/2を入力してOKボタンをクリックします。
  4. 値の設定ダイアログのOKボタンをクリック します。結果がワークシートに反映され、F(X)列ラベル行には式ではなく、(F1+F2)/2 が表示されます。

セル値の設定

Originは他のスプレッドシートプログラムが使用しているような、セルレベルの式をサポートしています。セルレベルの式は、ワークシートデータセルまたは、列ラベル行のユーザパラメータ行のセルに式を入力して値(数値、文字列、日時など)を出力できます。編集モード(編集: 編集モード)が有効な時はセル式が表示されます。編集モードが無効の時は、式の結果が表示されます。編集モードに関係なく、セルの内容は編集できます。

Set Cell Values 1.png


詳細は、数式を利用してセルの値を設定するをご覧ください。

Origin 2023におけるのセルの式の改善点

  • =記号を入力したときに表示されるオートコンプリートヒントの機能がOrigin 2023で改良され、関数のすべての引数が入力されるまでヒントが表示されたままになります。これは、値の設定ダイアログ、F(x)=ラベル行、およびセルの数式に適用されます。
  • セルの計算に対して定期的にリフレッシュが実行されます。シートに多数のセル数式が含まれている場合は、動作が遅くなる可能性があります。再計算の処理が煩わしい場合は、再計算再計算時間を管理するシステム変数@SCNT (デフォルトは5000ミリ秒)を使って、より長い時間を設定できます。後で強制的に更新したい場合は、スクリプトウィンドウ/コマンドウィンドウを開いて@SCNT = -1を実行します。

 

数式バー

セルまたは列の数式を作成する場合(F(x)=を使用)、数式バーを使用すると、関数の検索と挿入、セル範囲の選択、式の表示と編集、特にセル幅を超える長い式の表示と編集が簡単になります。

UG Formula Bar UI.png


セル(データセルまたはF(x)=)に式を入力するには、セルをクリックしてから、次の操作を行います:

  1. =」を入力して式を入力します。または、FB FunSel.pngボタンをクリックして関数の検索と挿入ダイアログを開きます。
  2. 目的の関数を検索し、ダブルクリックして数式バーの式に挿入します。
  3. ワークシートのデータ範囲を選択するには、(a)列ヘッダをクリックするか、(b)ドラッグしてセルの範囲を選択します。
  4. 式が完成したら、FB OK.pngボタンをクリックするか、Enterキーを押します。

数式バーの端をドラッグしてサイズを変更できます。デフォルトのフォントサイズを変更するには、 LabTalkシステム変数の値を変更します @FBFS (デフォルトでは「130」です)。

セル値の設定チュートリアル

チュートリアル1: セル式を他のセルに拡張

  1. 新規ワークブックボタンButton New Workbook.pngをクリックし、新しいワークブックを作成します。
  2. 列Aヘッダをクリックして列を選択し、右クリックして列値の一律設定: 行番号を選択します。
  3. B1セルをクリックして次のように入力します。
    =A1+A$1
    				
  4. ENTERキーを押します。A1の値にA1の値を足した結果が出力されます。
  5. セルを選択した状態のまま、セルの右下の角にカーソルを移動し、アイコンが+の形に変化したらダブルクリックすると、セルの計算式が列の下まで拡張されます。
  6. 列の追加ボタンButton Add New Columns.pngをクリックして新しい列Cを追加します。
  7. C1を選択し、ここでは次の式を入力します("$"を省略)。
    =A1+A1
    				
  8. ENTERキーを押します。A1の値にA1の値を足した結果が出力されます。
  9. セルを選択した状態のまま、セルの右下の角にカーソルを移動し、アイコンが+の形に変化したらダブルクリックすると、セルの計算式が列の下まで拡張されます。すると結果の値が異なることがわかります。
  10. メニューから編集: 編集モードを選択すると、実際のセル式が表示されます列Bの"$"は、2番目のセルA1 参照が他のセルでも変更されないように「ロック」しています。しかし、列Cでは省いたため、他のセルにセル式を拡張したときに変更されてしまったことがわかります。
Extending cell values.png

チュートリアル2: "This"を使って複数列をまたがって最大値を素早く検索

ワークシート列ラベル行(ワークシートヘッダ行)でセル式を使用できるのは、ユーザパラメータのみです。

  1. 新しいワークブックを作成し、メニューからデータ:ファイルからインポート: 単一ASCIIファイルを選択して\Samples\Import and Export\S15-125-03.datをインポートします。
  2. F(X)= 行ヘッダの左側にマウスカーソルを移動し、右向き矢印のアイコンに変化したら右クリックしてユーザパラメータの追加を選択します。
  3. 開いたダイアログボックスで、"MaxValue"と入力してOKをクリックします。
  4. A列のMaxValueセルに次式を入力します。
    =Max(This)
    				
  5. Enterキーを押すと、「10」が表示されます。
  6. 再度このセルをクリックして選択し、セルの右下角にカーソルを移動してアイコンが変化したらクリックして右にドラッグし、セル式をB(Y)C(Y)D(Y)列のMaxValueセルに拡張します。全てのMaxValueセルに各列の最大値が表示されます。

チュートリアル3: セル式で列ラベル行の値を使用

ユーザパラメータ行を含むワークシート列ラベル行のすべてのデータは文字列として格納されています。列ラベル行の値を数値としてセル式で使用するには、文字列を数値に変換する必要があります。次のサンプルでは、LabTalk関数value()を使って列ラベル行データを数値に変換し、セル式で使用できるようにします。

  1. 新しいワークブックを作成し、メニューからデータ:ファイルからインポート: 単一ASCIIファイルを選択して\Samples\Import and Export\S15-125-03.datをインポートします。
  2. F(X)= 行ヘッダの左側にマウスカーソルを移動し、右向き矢印のアイコンに変化したら右クリックしてユーザパラメータの追加を選択します。
  3. 開いたダイアログボックスで、 "Correction"と入力してOKをクリックします。
  4. 列DのCorrectionセルに0.2を入力します。
  5. 列の追加ボタンButton Add New Columns.pngをクリックして新しい列Eを追加します。
  6. E1セルに次のように入力します。
    =D1+value(D[Correction]$)
    				
  7. ENTERキーを押します。Correctionの値が数値に変換され、D1セルの値と加算されます。このセルには101.9と表示されます。


NOTE: 上述の"$" の式は、最初の散布図のように絶対セル参照を作成するようには機能しません。このコンテキストでは、文字列を数値に変換する前に、"$"構文を使用して、ユーザーパラメータセルの文字列変数を表現します。

データ範囲の名前付け

データ範囲に名前を付け、セル式列式で名前を使用したり、グラフの参照線を定義できます。

名前付き範囲は、列ラベル行でも使用できるので、たとえば、列値の設定の計算にラベル行のパラメータ値を組み込むことができます。


名前付き範囲を作成

UG named range dialog.png
  1. セルまたはセル範囲を選択して、データ:名前を定義を選択します。
  2. 新しい名前ダイアログで、選択範囲(参照範囲)につける名前を入力します。
  3. 名前付き範囲にスコープを設定します。
  4. オプション:名前付き範囲を使用して補間値を返す場合は、関数として定義にチェックを付けたえい、コメントを追加できます。


名前付き範囲の管理

  1. ワークシートをアクティブにして、データ:名前の管理を選択します。
  2. このダイアログで、名前、スコープ、範囲、コメントを修正できます。
UG named range manager.png

数式/リンクを削除

数式とリンクを削除すると、プロジェクトデータを同僚と共有するときに外部リンク(DDE)Excelファイルなどを共有しなくても可能になります。また、データをアーカイブする前にプロジェクトのサイズを大幅に縮小します。

UG remove formula links.png


数値データに変換できるもの:


このツールを開くには

  1. 編集:リンクを削除...を選択します。

詳細情報は、 Originのヘルプファイルをご覧下さい。

セルのノート

ワークシートのセル(データ行または列ラベル行)には、セルノートを含めることができます。データや、画像や埋め込みグラフなどの他のオブジェクトを含むものでも可能です(Note: リンクを含むセルはサポートされません)。

ワークシートセルのノートはリッチテキストをサポートしており、Originのリッチテキストシンタックスを使ってテキストスタイルを設定できます。さらに、画像やグラフを追加したり、ワークシートのセル値やレポートテーブルの値などにリンクしたりできます。詳細はレポート用のノートウィンドウを参照してください。

Origin 2023におけるのセルのノートの改善点

  • ワークシートの端にあるセルにノートを追加する際の問題を修正しました。セルに対するポップアップテキストボックスが、適切に配置されるようになりました。
UG cell notes edge window improve.png
  • セルのノートのプレビューフォントを制御するためのシステム変数@CNF (デフォルト=12)が追加されました (ノートウィンドウで開いたときのフォントとは無関係)。
  • ノートウィンドウで編集する際は、フォントサイズドロップダウンとフォントを大きくボタンとフォントを小さくボタンを使用できます。
  • 列リストビューでラベル行領域のセルノートがサポートされるようになりました。
UG column list view cell notes.png

 

  1. ノートを追加するには、ワークシートセルを選択し、ミニツールバーのノートを挿入ボタンをクリックしてテキストを入力します。
    UG addnote step1.png
  2. セルノートを編集するときは、書式ツールバーボタンを使用してテキストを書式設定します。
    OH format cell note in-place.png
  3. ノートのポップアップ名で右クリックすると、様々なOriginオブジェクトを挿入するショートかとメニューが利用できるほか、追加されたコンテンツに合わせてポップアップのサイズを変更したり、ノートウィンドウで生のテキストを編集できます。
  4. また、セルを選択してからミニツールバーのノートウィンドウで開くボタンをクリックしてノートウィンドウで開いて内容の編集が可能です。デフォルトでリッチテキストが有効になっています。
    UG addnote step2.png
  5. ノートウィンドウで編集するときは、書式ツールバーボタン(a)を使用してテキストを書式設定します。「レンダリング」モード(b)で表示するには、CTRL + Mタイトルバーを右クリック:レンダリングモード)を押します。完成したメモをワークシートのセルに挿入するには、閉じるボタンをクリックします(c
    UG addnote step2b.png
  6. ワークシートのセルにカーソルを合わせると、挿入されたメモが表示されます。
    UG cell notes RichText.png
Note:
  • 段落スタイルが割り当てられていないテキスト(次のセクションを参照)の場合は、書式ツールバーのフォントサイズを使用して、テキストサイズを制御できます。フォントサイズはウィンドウごとに設定できますが、すべてのノートウィンドウで共通のフォント(Segoe UIなど)を共有する必要があります。
  • Originは、@WNを使用したグラフの凡例とテキストオブジェクトでセルノートの「置換」をサポートしています。たとえば、1番目のプロットのソースワークシートのcol(B)の3番目のセルノートは、%(1, @WN, B, 3) のようにします。

テキストスタイルマネージャ

書式ツールバーを使用したテキストのスタイル設定に加えて、各行/段落に簡単なスタイルのセットを適用できます。テキストスタイルマネージャダイアログボックスでスタイルを管理します。

  1. ワークシートをアクティブにして、ツール:テキストスタイルマネージャを選択します。
  2. 変更するスタイルおよび適用または閉じるを選択します。
UG mod txt styles dlg.png

変更するスタイルドロップダウンリストから<新規> を選択すると、スタイルを追加できます。または、スタイルを選択して削除できます。

ノートウィンドウで段落スタイルを適用する方法

  1. ノートウィンドウでセルノートを開きます。
  2. レンダリングモードをオフにして(CTRL + Mで切り替え)、テキスト行をクリックして右クリックし、メニューから段落スタイルを選択してスタイルを選択します。
  3. 表示を確認するには、CTRL + Mを押してレンダリングモードをオンにします。

ワークシートデータを操作

Originでは。、ワークシートデータを処理する様々な機能を利用できます。ほとんどの機能はワークシートメニューにあり、それ以外は編集解析メニューにあります(ワークシートがアクティブでないと表示されません)。ショートカットメニューから利用できるユーティリティもあります。データを選択して右クリックします。

処理 メニュー操作
  • データの並べ替え

ワークシート: ソート(領域)
ワークシート: ソート(列)
ワークシート: ソート(ワークシート)
ワークシート: ソート(ラベル)

  • 検索
  • 置換
  • ジャンプ(シート行/列)
  • 列の選択/非表示

編集: プロジェクトを検索
編集: シートを検索
編集: 置換
編集: 行にジャンプ
編集:選択

Origin 2023では、編集:選択メニューを複製して、列:列を選択メニューとして表示しています。

また、モードLabTalkスクリプトによるオプションが追加され、フラアウトメニューから簡単なサンプルを利用できます。

 

UG select hide cols dlg.png

  • 列を隠す
  • 行を隠す

列: 列を隠す/再表示

行を隠す/隠さない(ショートカットメニューのみ)

  • 列の移動
  • 列の交換

列:列の移動またはツールバー

列: 列の交換

  • ワークシートデータクエリ

ワークシート:ワークシートクエリ

  • 列を別の場所にコピー

ワークシート: 列のコピー

  • ワークシートの追加

ワークシート: ワークシートの追加

  • ワークシートを結合する

ワークシート:列でワークシートを結合する
ワークシート:ワークシートをラベルで結合する

  • 列データの分割
  • ワークシート分割
  • ワークブックの分割

ワークシート:列データの分割

ワークシート:ワークシートの分割

ワークシート:ワークブックの分解

  • セルの文字列を複数列に分割

メニューなし。ダイアログボックスを開くには

  1. ウィンドウ:スクリプトウィンドウ を選択します。
  2. text2cols -dを入力してEnterを押します。


詳細は、このリンクをご覧ください。

  • グループ化して複数の列を1つにスタックする
  • グループデータを複数列にアンスタックする
  • 複数のシートに共通の列をラベルによってスタックする

ワークシート:列スタッキング

ワークシート:列アンスタッキング

ワークシート:ワークブックの共通ラベルで列をスタック

Origin 2023列アンスタッキングの機能が改良されました。(A) グループ情報の出力先 = カスタムで、(b) グループ情報を格納するためのラベルで1つ以上のユーザパラメータを使用してラベル付け出力を指定し、(c)グループ列にロングネームがある場合、出力ワークシートで出力を識別するためのユーザパラメータ行としてロングネームを付けます。

 

ワークブックでシートを非表示にできるようになりました。この変更に対応するために、ワークシートのスタック非表示のシートをスキップチェックボックスが追加されました。

 

  • ピボットテーブルでデータを要約する

ワークシート:ピボットテーブル

  • 1列、または複数列をある定義条件によってフィルタリング

列:フィルタメニューまたは、ワークシートデータ操作ツールバー

参考: データマスク操作

  • データ削減

ワークシート: 重複行の削除
ワークシート: 列の削減
ワークシート: 行の削減
解析: データ操作: データ削減:重複X
解析: データ操作: データ削減:クラスタX
解析: データ操作: データ削減:等間隔X

Origin 2023の追加機能

  • 列の削減 (wreducecols) の新しい統合する方法オプションが追加され、複数の値の出力を指定できるカスタムオプション (平均と標準偏差など) を利用できます。
  • グループの数による削減(reducexy) ダイアログボックスの新しいサブグループ化の方法=参照列によるを追加しました。
  • データ削減の出力(X ファンクション = Reducedup、reducexy、reduce_ex) において、主要なメソッド情報を保存するラベル行Methodが作成されます (システム変数@CCL = 1 )。また、出力シートで使用されるソースシートからのロングネームと単位を表示します (以前は、分析操作に関する一般的な情報がタグ付けされていました)。

 

  • ワークシートデータ転置

ワークシート:データ転置

  • ワークシートデータ変換

XYZ形式に変換行列に変換

  • 条件付きフォーマットをワークシートセルに適用する

ワークシート:条件フォーマット:ハイライト
ワークシート:条件フォーマット:ヒートマップ
ワークシート:条件フォーマット:重複検出

  • 逆順

列:列の反転

ワークシートデータの条件フォーマット

上記のワークシートデータユーティリティに加えて、Originワークシートは条件フォーマットをサポートしています。条件フォーマットには3つのモードがあります。

US Temperature Data wMap Overlay.png

条件フォーマットマネージャを使ってアクティブシートの条件フォーマットを管理します。

3色限定混合を使用してワークシートヒートマップの色を塗る場合、中央の色の位置を指定できるようになりました。パーセンタイルによる、パーセントによる、によるから指定します。

ワークシートデータを保護

Origin 2023からワークシート保護のGUIアクセスが可能になりました。

 

1つまたは複数のワークシートに保護を適用し、その過程でいくつかの例外を設定できます。

UG worksheet data protection.png


どの操作の場合も、シート保護オプションダイアログが開き、例外の設定が可能です。このダイアログは、環境設定:シート保護オプションをクリックしても開くことができます。

UG protect worksheet options dialog.png
  1. 1つ以上のワークシートの保護を解除するには、シートレベルのミニツールバーボタンのシート保護をクリックしてアイコンのチェックマークを外します。あるいは、オブジェクトマネージャかシートタブを右クリックしてシート保護を選択してチェックマークを外します。

分析とレポートのためのワークブック

テキストおよび数値データの他に、ワークブックにはさまざまな種類の情報を含めることができます -- 画像、グラフ、ノート、行列;他のワークブックセルの値へのリンク、プロジェクト変数、ドキュメント、ウェブページ;さらにはインポートファイルのメタデータ、変数やスクリプト -- などです。これらの要素により、ワークブックを研究データを収集したり、カスタムレポートを作成するための柔軟な媒体として利用できます。

さらに、ワークブックは複雑な一連の分析操作を「格納」することができます。例えば、適用されたデータフィルタ、フィルタリングデータのフィット操作、カスタマイズされた結果のプロットなどを、分析テンプレートというものに格納します。分析テンプレートを使用すると、新しいデータを入力するだけで、結果のカスタムレポートを自動的に生成することができます。


Custom worksheet report.png

レポートを生成するための選択肢の1つ は、カスタムMS Wordテンプレート、あるいは、PDFファイルへのデータエクスポートです(他の方法は、このセクションの一番下にあるヒントを参照してください)。これを行うには、Originで出力を生成する分析を実行し、主要な結果をWord テンプレートのブックマークに関連付け、最後にワークブックを分析テンプレートとして保存します。レポートを作成するには、バッチ処理ツールを開き、分析テンプレートとWordテンプレートの両方を選択してバッチ処理を実行し、レポートを作成します。

Word report template PDFout.png

レポート作成のほかのオプションとして、Originのノートウィンドウを使ってHTMLレポートを作成することもできます。ノートウィンドウは、直接またはプレースホルダシートを使用して、グラフ、ワークシートセルなどにリンクできます。詳細は、ノートウィンドウからHTMLレポートを作成をご覧ください。

参考