データのインポート

Import grand image4 650px.png

Origin 2019bでデータコネクタと呼ばれる新しいデータインポートの仕組みが追加されました。名前の通り、データコネクタはプロジェクトと外部のソースファイルの間にリンクを作成します。ソースファイルはローカルにあっても、会社のネットワーク上にあってもかまいません。Webサーバ上に置くこともできます。データコネクタは、プロジェクトを保存時にインポートデータを含まずに保存するオプション(ファイルサイズを軽くし、ソースデータへのリンクを維持)と、偶発的な変更または削除操作からデータを保護するオプションをサポートします。データコネクタは、HTMLテーブルJavaScript Object Notation (JSON)データなど、これまで利用できなかったデータソースのインポートをサポートします。 データコネクタは、ドラッグアンドドロッププロジェクトオープン時の自動インポートをサポートします。さらに、OriginLabでは新しいデータ形式への対応を進めています。たとえば、Origin 2021bでは、National Instruments TDMSおよびNetCDFファイル用のコネクタが改善されました。 さらに、新しいThermo Fisher Scientific MSRawFileコネクタを追加しました。


その他のサポートされているインポート方法:

目次

アップグレードユーザ向け情報

以前のバージョンでは、ファイルメニューにあったインポートルーチンが、最近のバージョンではデータメニューに移動していることに注意してください。Originの最新のデータインポートツールであるデータコネクタがあります。

Import fF Moved.png

データコネクタ

Origin 2023ではデフォルトでXMLコネクタがインストールされています。

 

Data Connector General Concept.png

データコネクタは、ローカルまたはwebベースのファイルやページからOriginプロジェクトにデータをインポートするための一般的なメカニズムです。データコネクタは、主に2つのデフォルト(変更可能な)の古いOriginのインポート方法とは異なります。


データコネクタは多数の一般的なデータフォーマットをサポートしています。

SQLデータベースに接続するには、データベースを参照してください。


データコネクタでデータをインポートする方法

  1. ワークブックをアクティブにして、データメニューをクリックします。

Origin 2023では、Webに接続ダイアログでは、最近使ったURLからサンプル URLが分割して表示されます。最近使ったURLには引き続き接続先がリストされますが、サンプル URLにはCSVHTMLJSON、およびMATLABの場合の接続の例が表示されます。

Connect to web dialog samples 2023.png

 

データコネクタについて知っておくべきこと

Data Connector Shortcut Menu.png
UG data connector add new.png

Originは、 データ:Webに接続によってインポートされたデータを、LabTalkのシステム変数 @CFDTとファイルサイズで決定された期間キャッシュします。デフォルトでは、10MBのファイルの場合キャッシュされたデータを24時間保存します。つまり、24時間以内に再インポート(つまり、Webファイルに再接続)した場合、最初のインポートでキャッシュされたデータが使用されます。24時間経過後、この10MBのファイルに再インポートすると、キャッシュがクリアされ、データが新たにインポートされます。このキャッシュに関する動作を制御する方法については、以下のトピックを参照してください。

データソースファイルパス

データコネクタアイコンは、次の5つの状態のいずれかで表示されます。


接続の状態に関係なく、コネクタアイコンをクリックし、データソースファイルパス共通データパスを使用して、Originファイルとソースデータ間の接続を維持できます。

UG Common Data Path Dialogs.png

データナビゲータ

データナビゲータは、Excel、MATLAB、Originプロジェクトなどの複数ページ/複数変数のファイルに接続したときに、ブックに自動的に追加される折りたたみ可能なパネルです。

UG data navigator overview.png

データコネクタとドラッグアンドドロップ

データ: ファイルに接続にあるファイルタイプでドラッグアンドドロップがサポートされています。

Text/CSVに接続

データコネクタを使用して、ローカルまたはWebに保存されたテキストファイル(TXT、DAT、CSV)をインポートできます。データコネクタ機能は、これらのファイルタイプで適切に機能し、Originの古いX-Functionベースのインポートルーチンに関連する問題の一部を簡素化し、場合によっては排除します。たとえば、日時データのインポートでは、常に日時列は手動で構成する必要がありました。コネクタを使用すると、日時データが標準の簡単に認識できる形式である場合、その構成は自動的に行われます。

Origin 2023でのOriginのテキスト/CSVおよびExcelコネクタの改善

  • ファイル名による名前変更:CSVのみ。シートブックロングネームのオプションがあります。
  • デフォルトに保存: CSVのみ。スパークライン名前変更の設定をデフォルトに設定するボタンです。
  • インポート後に実行するLabTalkスクリプト: インポート時のデータの後処理を行うスクリプトを実行します。
UG CSV Excel Other Options.png

 


ローカルドライブまたはLANドライブ上のファイルに接続するには:

  1. ワークブックをアクティブな状態で、メニューからデータ:ファイルに接続: Text/CSVを選択します。
  2. ファイルを参照して選択します。
  3. CSVインポートオプションを設定します。多くの場合、デフォルトを受け入れるだけでファイルがきれいにインポートされるため、テストとして、デフォルトを変更せずにデータをインポートしてみてください。結果が良くない場合は、インポートを再実行してデフォルト設定を変更します。

このミニチュートリアルでは、Text/CSVコネクタを使用して、日時コンポーネントを含むテキストファイルをインポートします。古いOriginのインポート方法では日時データがテキストとして扱われ、ユーザーは手動で日時列をインポート後の日付に設定する必要がありましたが、Text / CSVコネクタはインポート時にワークシート列を自動的に構成できます。

  1. 新規ワークブックボタンButton New Workbook.pngをクリックし、データ:ファイルに接続:Text/CSVを選択します。
  2. <Origin Program>\Samples\Import and Export\フォルダを参照し、Date with higher precision.dat.を開きます。
  3. CSVインポートオプションダイアログの設定はデフォルトのままにして、 OKをクリックします。データがワークブックにインポートされます。
  4. Aヘッダをクリックして列を選択し、右クリックして列プロパティを選択します。フォーマットは自動的に日付に設定され、表示カスタムに設定され、カスタムフォーマットはカスタム表示に表示されることに注意してください。
Import custom date time.png

このミニチュートリアルでは、データコネクタを使用して複数のファイルをインポートします。これらの同じ構造のファイルには、保持したいメタデータの複数の行があります。したがって、インポートフィルタを使用して作られたインポートフィルタファイルを使用して、ファイルをインポートし、ファイルメタデータを各ワークシートの複数の列ラベル行に書き込みます。そうすることで、(a)データコネクタを使用して複数のファイルをインポートする方法、および(b)以前のバージョンのOriginで開発されたインポートフィルタファイル (*.oif)を使用して、Originの新しいデータコネクタテクノロジーを使用してファイルをインポートする方法を確認できます。

  1. 新しいプロジェクトを開始し、ワークブックをアクティブにして、データ:複数ファイルに接続を選択します。
  2. files2dcダイアログボックスで、以下のように設定します。
    • データコネクタ = インポートフィルタ
    • ソース = 指定したファイル
    • ファイル名 = <Origin Program>\Samples\Import and Export\S15-125-03.dat, S21-235-07.dat and S32-014-04.dat
    • 同一ブック = 有効(チェックボックスをオンにすると、すべてのファイルが1つのブックになります)
  3. OKをクリックし、開かれたダイアログで、インポートフィルタ = データフォルダー:VarsFromFileNameAndheader.oif]を設定します。
  4. OKをクリックすると、3つのファイルがワークブックに別々のシートとしてインポートされます。


Web上のファイルに接続するには:

  1. データ:Webに接続
  2. ファイルのURLがある場合は、URLボックスに入力します。それ以外の場合は、ファイルタイプText/CSVに設定し(オプションですが、最近使ったURLをフィルタリングするのに役立ちます)、最近使ったURLを直接クリックして、リストから選択します。
Connect to web dialog URL.png

CSVインポートオプション ダイアログを使用して、ローカルに保存されたファイルと同様、Webに保存されたファイルの部分インポートを指定できます。部分インポートボックスをチェックして、およびインポートを定義するために使用しるシンタックスのガイドを開きます。

Note:Text/CSVコネクタと一緒に操作する方法についての詳細は、次のOriginヘルプを確認してください。

ヘルプ: Origin: Originヘルプ > Text/CSVコネクタ

MATLABファイルに接続する

Originは、これまでのXファンクションベースのMATファイルインポートを引き続きサポートしていますが、データコネクタにはローカルに保存されたMATLABファイルとWebに保存されたMATLABファイルの両方のインポートにいくつかの利点があります。

UG slider or thumb MAT.png


MATLABファイルに接続するには:

  1. ワークブックまたは行列ブックをアクティブにして、データ: ファイルに接続: MATLABまたはデータ: フWebに接続をクリックして、.matファイルへのURLを入力します。
  2. インポートする変数を選択し(ブラウザの下部パネルに追加します)、OKをクリックします。


Note:JSON/MATLABコネクタと一緒に操作する方法についての詳細は、次のOriginヘルプを確認してください。

ヘルプ: Origin: Originヘルプ > JSON/MATLAB

NetCDFファイルとシェープファイルに接続する

NetCDFファイル形式は、多次元の科学データを共有するために使用されます。主に気候科学で広く使用されています。シェープファイルは通常、地理的境界やその他の地理空間データを格納するために使用されます

Import NetCDF Image Map.png


NetCDFファイルに接続するには:

  1. ワークブックまたは行列ブックをアクティブにして、データ: ファイルに接続: NetCDFまたはデータ: Webに接続をクリックして、.ncファイルへのURLを入力します。
  2. インポートする変数を選択しブラウザの下部パネルに追加します。
  3. 必要に応じてインポートオプション(鉛筆ボタン)を調整してOKボタンを2回クリックします。
  4. ワークブックがアクティブであるが、変数に行列ブックが必要な場合は、アクティブなワークックに新しい行列ブックまたは埋め込み行列ブックを追加するように求められます。


シェープファイルに接続するには:

  1. ワークブックまたは行列ブックをアクティブにして、データ: ファイルに接続: Shapefileをクリックして.shpファイルを選択します。
  2. (オプションで)エンコーディングと属性をロードWGS84に変換を指定し、OKをクリックします。

Origin 2023では、ShapefileインポートオプションダイアログにWGS84に変換チェックボックスが追加され、メートル単位の距離を持つシェープファイルを経度と緯度を持つ WGS システムに変換します。

UG shapeifle options wgs84.png

 

.
Note:NetCDFコネクタと一緒に操作する方法についての詳細は、次のOriginヘルプを確認してください。

ヘルプ: Origin: Originヘルプ > NetCDFコネクタ

クラウドドライブに接続

MS OneDrive または Googleドライブに保存されているOriginMS ExcelASCIIファイルに接続可能です。アカウント認証後、ローカルファイルへの接続と同じようにクラウドファイルへの接続が可能です。

  1. ワークブックをアクティブにして、データ:クラウドに接続をクリックします。ブラウザが開いたらファイルを選択します。
  2. 必要に応じてブラウザのドロップダウンでクラウドサービスやアカウントの選択を行います。
    Data Connect to Cloud Browser.png
  3. ファイルを選択して、開くをクリックします。

初めてクラウドアカウントに接続するときは、アカウントの確認が必要です。Originは一時ファイルを使用して、クラウドアカウントとローカルコンピュータ間でデータにアクセスして転送します。それ以外の情報の通信は実行されません。

Excelデータを操作する

OriginでExcelデータを扱う場合、複数の方法があります。


OriginでExcelを操作する際の注意事項


Note:Excelデータの操作についての詳細は、次のOriginヘルプを確認してください。

ヘルプ: Origin: Originヘルプ > Microsoft Excelの操作およびファイルに接続 > Excel

ExcelコネクタimpMSExcel ルーチンは、Excelファイルの部分インポートをサポートしています。詳細は、Originヘルプの部分インポートと再インポートを参照してください。

Excelファイルに接続する

Text/CSVExcelコネクタの新しいインポートオプションに加えて、Origin 2023では、Excelコネクタでのインポートで結合されたデータセル のの取り扱いが改善されました。

  • Excelインポートオプションコメントとして指定されているラベル行の結合セルの場合、(1) 垂直方向に結合された値が1つの値としてインポートされます。(2) 水平方向に結合された値は、結合されたセル全体で複製されます。
  • データ領域 (3) の結合セルは保持されません。結合されたセルの値は、セル全体で複製されます。

UG merge cells on XLS import.png

 

Originのデータコネクタは、Originプロジェクトの外部データファイルとのライブリンクを作成します。

Excel connect import options structure.png
  1. 新規ワークブックButton New Workbook.pngボタンをクリックして新しいワークブックを作成し、データ:ファイルに接続:Excelを選択します。
  2. <Origin Program>/Samples/Import and Export/United States Energy (1980-2013).xlsを検索し、開くをクリックします。
  3. Excelインポートオプションダイアログの設定はデフォルトのままにして、 OKをクリックします。
  4. ブックの左側に表示されるデータナビゲータパネルで、Ctrlキーを押しながら他の3つのシートを選択し、右クリックしてシートの追加と接続を選択します。残りのシート(Natural GasCoal、およびTotal Primary Energy)はワークブックにインポートされます。接続されていないシートのサイズが大きい場合は、必要に応じて、一度に1枚ずつ接続することを選択できます。

ファイルからインポート

データ: ファイルからインポートの下にリストされているインポートルーチンは、データコネクタより前のものです。ファイルからインポート機能は今後開発されることはありませんが、利用できます

また、この表にあるファイルの種類によっては、コネクタが存在しない場合があります。データコネクタがない場合は、データ:ファイルからインポート機能を使用する必要があります。

標準ツールバーの単一ASCIIのインポートボタンButton Import ASCII.pngで、データ:ファイルに接続: Text/CSVルーチンが呼び出されるようになりました。impASCルーチンについては、次のセクションを参照してください。

impASCでASCIIファイルをインポート

Import data 1.png
Note:impASCダイアログを使用したASCIIインポートについての詳細は、次のOriginヘルプを確認してください。

ヘルプ: Origin: Originヘルプ >ASCIIインポートオプションのカスタマイズ

インポート設定を保存

impASCダイアログでインポート設定を調整した場合、次の2通りの方法でこれを保存できます。

ワークシートテンプレートを使用してインポート設定を保存すると、移植性が向上します(テンプレートは同僚と簡単に共有できます)。テーマとしてインポート設定を保存すると、impASCダイアログボックスでインポートするときにインポートオプションの組み合わせをいくつでも呼び出せるという利点があります。

テーマとテンプレートの詳細については、このユーザーガイドの後の章にあるOriginのカスタマイズをご覧ください。またに、下の「詳細情報」にある、トピックスもご覧ください。

データメニューの下部にあるリストからカスタムインポートテーマをすばやく読み込むことができます。また、データ:ファイルからインポート:ファイルの種類の追加/削除と選択して開く、インポートメニューのカスタマイズダイアログを使用して、保存したユーザテーマデータ:ファイルからインポートで表示されるサブメニュー内に表示させることができます。

サードパーティ製データ

特定のサードパーティ製のデータコネクタが存在しない場合でも、Originの古いX-Functionベースのインポートルーチンを使用できます。これらには、pClamp、NI TDM、NetCDFなど、広く使用されている含む幅広いサードパーティ製データが含まれます。すべてのX-Functionベースのルーチンと同様に、サードパーティのファイルインポートオプションをカスタマイズし、ワークシートテンプレートを使用して、または後で使用するためのダイアログテーマとして設定を保存できます。サポートされている他のファイルタイプと同様に、ドラッグアンドドロップでサードパーティのファイルをインポートできます。

ファイルの種類 方法 より詳細をご覧いただくには次を参照してください:

ヘルプ:Origin:Originヘルプ > データのインポートとエクスポート


Thermo (SPC, CGM)
pCLAMP (ABF, DAT, AB?)
Princeton Instruments (SPE)
音声(WAV)
NetCDF (NC)
CDF (CDF)
HDF5 (H5, HE, HDF5)
NI DIAdem (DAT)
Famos (DAT, RAW)
ETAS INCA MDF (DAT, MDF)
IgorPro (PXP, IBW)
Prism (PZFX, XML)
MATLAB (Mat)
Minitab (MTW, MPJ)
KaleidaGraph (QDA)
SigmaPlot (JNB)
MZXML(mzData, mzXML, mzML, imzML)
EarthProbe (EPA)
EDF (EDF, BDF, REC, HYP)
Somat SIE (SIE)
JCAMP-DX (DX, DX1, JDX, JCM)
HEKA (DAT)
SPSS (SAV)
BRUKER OPUS
SAS (sas7bdat)
Tektronix (ISF)
Data Translation (DCF, HPF)
バイナリ2D配列 (IMG, B2D)
画像

データ:ファイルからインポート > サードパーティ製ファイルのインポート
Note:デフォルトでは非表示になっているサードパーティ製ファイルフォーマットもあります。追加するには、データ:ファイルからインポート:ファイルの種類の追加/削除...を選択します。これにより、インポートメニューのカスタマイズダイアログボックスが開き、ファイルからインポートメニューに表示するファイルの種類を選択できます。もし、メニューコマンドの間に区切りが必要な場合、このダイアログの右側のパネルで右クリックし、区切りの追加を選択します。区切りを削除するには、右側のパネルで区切りをダブルクリックします。

特定のファイルタイプ(つまり、上記の表にリストされているもの)にデータコネクタが存在しない場合、ドラッグアンドドロップのサポートは、フィルタマネージャーダイアログを使用してファイル拡張子によって管理されます。メインメニューから、環境設定:基本設定:インポートフィルタマネージャ...をクリックします。

Note:サードパーティー製ファイルと一緒に操作する方法についての詳細は、次のOriginヘルプを確認してください。

ヘルプ:Origin:Originヘルプ > サードパーティ製ファイルのインポート

インポートウィザード

上記2つの方法では十分に扱えない、複雑な構造のASCIIファイルをインポートする場合、インタラクティブなインポートウィザード を使用します。任意のヘッダ部とその後にバイナリデータが続くような構造を持つバイナリファイルはOriginのインポートウィザードでインポートします。

ASCIIデータでインポートウィザードを使用するもう1つの利点は、同じ名前のデータファイルのグループを対象とするインポートフィルタを作成できることです。これは、ファイルに特定の方法で処理する必要のあるメタデータが含まれている場合に役立ちます。作成したフィルタは、ドラッグアンドドロップによるインポート操作で使用でき、データ:ファイルからインポートメニューに追加できます。

Origin 2023では、PythonまたはOrigin Cコードを使用して開発されたインポートフィルタ (*.oif) の編集が可能なGUIが追加されました。

  • このダイアログは、環境設定: インポートフィルタ・マネージャを選択して開きます。フィルタを選択して編集ボタンをクリックします。User Files\Filtersフォルダ二のユーザ定義フィルタがここに一覧表示されます。
  • wFilterダイアログには、ユーザ定義ブランチが追加されています。Pythonコード (コードを追加または編集するためのテキストボックス付き)、.pyファイルを指定するためのPythonファイルソースファイル関数名を指定するためのOrigin Cの3つのオプションがあります。
UG iwfiilter dialog.png

Originでのプログラミングオプションに関する情報は、Originのプログラミングの章を参照してください。

 


インポートウィザードを開くには:

  1. データ:ファイルからインポート:インポートウィザードを選択するか、標準ツールバーにあるButton Import Wizard.pngボタンをクリックします。


Note: 詳細は、次のヘルプファイルをご覧ください。

ヘルプ:Origin ヘルプ > データのインポートとエクスポート > インポートウィザード

クリップボードのデータをコピー/貼り付け

Originでデータを取得するひとつの方法として、クリップボードにコピーしたデータをOriginに貼り付ける、という方法があります。 これで、Excelワークブックの一部分を選択し、Originのワークブックに貼り付けるという簡単が可能です。しかし、クリップボードのデータは、Originへ正しくデータを貼り付けることができるように、フォーマットされた配列、または区切りではありません。ここではいくつかの注意点があります。

Import data wizard composite resample office 600px.png

Originファイルをクエリして選択的にデータをインポート

インポートに先立ってデータコネクタブラウザでSQL同様のクエリの指定により、外部Originファイルからデータ列を選択的にインポートできるようになりました。

UG Import Origin SQL.png

Originコネクタを使ってOriginファイルを選択的にクエリ

  1. ワークシートをアクティブにして、データ:ファイルに接続または、Webに接続を選択します。
  2. Originファイルを参照して、開くをクリックします。データコネクタブラウザが開きます。
  3. クエリを選択ボタンUG Select Query Button.pngをクリックします。
  4. クエリを選択ダイアログでクエリを入力し、OKボタンをクリックします。

クエリで指定した通りに、アクティブワークブックに選択的にデータがインポートされます。


一般的なキーワード

キーワード 説明
_SName ショートネーム。例:_SName, Sheet_SName
_LName ロングネーム。例:_LName, Book_LName
_Comments コメント。例:_Comments, Sheet_Comments
Column_D1 列ユーザ定義パラメータで、1 はパラメータ番号
Column_[Name] 列ユーザ定義パラメータで、[Name] はスペースを含めたパラメータ名


サンプル:

Select Column from Project where _SName == "A";
Select Column from Project where _Comments like "S*3";
Select Column from Project where (Column_P1 like "*y*" and Column_D1 > 3);
Select Column from Project where Sheet_SName like "Trial*";
Select Column from Project where (Book_SName like "Book*" or Book_LName like "*fit*")


詳細情報は、ユーザガイド: OriginコネクタでSQLクエリを使用するサンプルを参照してください。

データベース

Originは、ODBCとOLE DBによるデータベースへの接続をサポートしています。さらに、Originには、接続文字列を追加し、Origin内でSQLクエリを生成するためのシンプルなSQLエディタが含まれています。


SQLデータをインポートするには、データ:データベースに接続メニューコマンドから開始します。

UG database connector dialog.png


他の事項:

DB Save wo data.png
Note: 詳細は、次のOriginヘルプを参照してください。

ヘルプ:Origin:Origin ヘルプ > データのインポートとエクスポート > データベースからデータをインポートする

デジタイザ

詳細に探求したい、いくつかのデータのグラフ画像のみある場合、デジタイザを使って、イメージファイルをインポートします。そして、Originの分析およびグラフ作成ツールを使って、イメージを検定や再プロット可能な数値データに変換して、プロットをデジタイズします。

Digitizer data import chapter 2.png


デジタイザを開くには

  1. 標準ツールバーのイメージのデジタイズボタンButton Digitize Image.pngをクリックするか、メインメニューの ツール:デジタイザ...を選択します。

インポートデータを除外してOriginファイルを保存する

今までの方法でも、Originデータをデータなしで保存することはできました。テンプレートとして保存...ワークブックを分析テンプレートとして保存プロジェクトをデータなしで保存は、ファイルと設定や操作を維持しながら、データのない起源ファイルを保存するための3つのオプションでした。

また、インポートされたデータなしでOriginファイルを保存することができるようになりました。これは、大きなデータファイルを扱うユーザにとっては特に便利なオプションです。ファイルを使ってそのデータを保存すると、パフォーマンスが低下したり、ディスク容量が無駄になったりする可能性があります。

Exclude imported when saving.png
Exclude imported when saving Properties dialog.png


保存時にデータを除外するという動作は、いくつかの重要な点でテンプレートファイルの保存とは異なります。

データファイルの再インポート

データメニューには、同じファイルを繰り返しインポートするための2つのインポートコマンドがあります(ファイルパスと名前は同じである必要があります)。

Note:

  • 一度に再インポートできるのは1つのファイルだけです。 これら2つのメニューコマンドのいずれか1つを使うと、アクティブワークシートあるいは行列シートと結びついたファイルのみがインポートされます。 選択したデータを複数のファイルからインポートすると、再インポートは失敗します。
  • ASCIIファイルをインポートウィザードを使ってインポートしてデータ: 再インポート...を選択する場合、インポートウィザードの代わりにimpASCダイアログが開きます。
  • 再インポートは、インポートウィザードを使ったバイナリまたはユーザ定義データタイプでは操作できません。

クローンインポート

クローンインポートは、インポート(および、オプションで関連する分析操作)を「モデリング」し、最初のファイルに対して行われた内容を一連の類似ファイルに適用する機能です。アクティブなブックにインポートされたデータと関連する操作が含まれている限り、クローンを作成できます。この意味で、クローン作成は分析テンプレートの作成に似ていますが、いくつか制限があります(たとえば、バッチ処理ツールでは使用できません)。

クローンインポートは、データコネクタXファンクションベースのインポート方法の両方でサポートされています。簡単なチュートリアルで、クローンインポートと分析操作の基本について説明します。

  1. 新規ワークブックボタンButton New Workbook.pngをクリックし、新しいワークブックを作成します。
  2. ファイルエクスプローラーを使用して、<Origin Program>\Samples\Curve Fitting フォルダーを参照し、Sensor01.datというファイルを見つけます。このファイルを新しいワークブック内にドラッグアンドドロップします。Text/CSV コネクタを使用して.datファイルをインポートします。
  3. 列Bのヘッダをクリックして列を選択し、散布図ボタンButton Scatter.pngをクリックして散布図を作成します。
  4. XまたはYグラフの軸スケールをクリックし、表示される ダイアログボックスで スケール タブをクリックし、Ctrlを押して、左側のパネルで水平軸アイコンと垂直軸アイコンの両方を選択します。再スケール自動 に設定して、OKをクリックします。
  5. グラフがアクティブな状態で、 解析 : フィット : 線形フィット をクリックして、ダイアログボックスを開きます。再計算自動に変更し、他の設定はデフォルトのままOKボタンをクリックしてフィットを実行します。確認メッセージに「いいえ」と答え、OKをクリックします。
  6. ワークブックのタブを1つ右クリックし、グラフをシートとして追加をクリックします。これにより、線形フィットの結果を含む散布図がワークブックのページとして追加されます。
    UG clone import add graph.png
  7. Sensor01.datのデータがアクティブな状態で、インポートツールバー上のクローンインポートボタンButton Clone Import.pngをクリックします。
  8. もう一度、<Origin Program>\Samples\Curve Fitting フォルダを参照し、CtrlキーまたはShiftキーを押して、Sensor02.datからSensor07.datファイルを選択します。ファイルの追加をクリックし、OKをクリックします。元のブックをインポートおよび分析操作のモデルとして使用すると、SensorファイルはText / CSV コネクタを使用してインポートされ、1つずつ処理されます(すべて完了するまでに数秒かかる場合があります)。
    UG clone import results.png

参考