Originのインターフェース

目次

Originのワークスペース

この章では、Origin ワークスペースのナビゲートに関する基本的な情報を提供しています。長年Originをご利用の方は、この章は読み流していただいても問題ありません。

GSB Origin Interface.png

ウィンドウのサイズとワークスペース内の位置は、さまざまな表示に対応するように自動調整されます。これにより、すべてのウィンドウやダイアログボックスのサイズを変更/再配置しなくても、例えば、ノートPCと高解像度モニターで表示を統一できます。再スケール動作を制御するためのシステム変数@SRWS0 =以前の動作、1 =幅を合わせ、yをスケール、2 =高さを合わせ、Xをスケール、3(デフォルト)=幅と高さを合わせる)が追加されました。

Windowsファイルエクスプローラでのプレビュー

Originインターフェイスの一部ではありませんが、Windowsファイルエクスプローラ(以前のWindowsエクスプローラ)を使用して、プロジェクトファイル内のグラフをプレビューできます。

Interface Windows Explorer2.png

Originのメニューとメニューコマンド

Origin 2023ではすべてのOrigin ファイル アクティビティのプレーンテキストログが追加されます。ファイルは「OriginProjHistory.txt」という名前で、ユーザファイルフォルダ (ヘルプ: フォルダを開く: ユーザファイルフォルダ) に保存されます。ログのエントリ最大数は、システム変数@MHF (デフォルト = 1000) によって制御されます。

Originのツールバー

Origin 2023では、ツールバーのレイアウトが若干変更されました。プロジェクトエクスプローラのフォルダとフォルダの内容を操作するための新しいツールバーフォルダとウィンドウが追加されました。Origin 2023の初回起動時に、このツールバーがフローティング状態でOriginのワークスペースに追加表示されることがあります。その場合、タイトルバー部分をドラッグしてツールバー領域の空いている部分に配置したり、表示:ツールバーを選択して再初期化ボタンをクリックすることでツールバーの構成を2023用にリセットすることができます。

UG folders windows toolbar.png

また、使用頻度の低いツールバー(矢印の操作レイアウト)はデフォルトで非表示になりました。ツールバーの構成についての情報は、ツールバーとボタンのカスタマイズを参照してください。

ツールバーのカスタマイズダイアログ(表示:ツールバー)を使って、ツールバーの表示を設定したり、リセットや初期化することができます。

UG hide-show toolbar buttons.png
UG alt-drag toolbar button.png

Originの標準ツールバーについての情報は、このユーザガイドの後に、ツールバーとボタンのカスタマイズを参照してください。

ミニツールバー

OriginLabは、一般的なオブジェクトとタスクのため、ミニツールバーのサポートを改善し続けています。これらのツールバーは、がオブジェクトを選択したとき、または、ページ内の特定の領域をクリックしたときに表示されます。利用できる設定項目は、コンテキスト(オブジェクト、ウィンドウタイプなど)に依存します。

UG interface mini toolbars.png
UG sheet toolbar cursor.png
UG customize mini toolbar dialog.png

スタートメニュー

検索ツールボックスにキーワードとフレーズを入力して、メニュー項目、アプリFAQsビデオXファンクションを検索します。最近使用したファイルメニューアプリを開きます。

(1)F1を押すか(他のダイアログが開いていないとき)、(2)Originワークスペースの左下隅にある虫眼鏡アイコンをクリックする、またはメインメニューの(3)ヘルプ:スタートメニューをアクティブにする項目をクリックしてスタートメニューを開きます。

Start menu result.png

検索範囲を絞り込むには、検索語句の前に次の文字を入力します:

m = メニュー項目のみ検索
a = アプリのみ検索
h = ヘルプとFAQのみ検索
v = ビデオのみ検索
x = Xファンクションのみ検索
p = 最近使用したプロジェクトを検索
s = サンプルプロジェクトを検索
e = メニュー、アプリ、Xファンクション(実行可能なもののみ)を検索

その他の方法

検索ボックス付近の「歯車」アイコンをクリックして設定ボックスを開きます。ここでは、検索結果を制限し、他の検索設定を調整することができます。

Start menu settings.png

ラーニングセンター

ラーニングセンターは、グラフ作成と解析のサンプルに加えて、学習リソース(チュートリアル、ビデオ、OriginLabブログなど)にすばやくアクセスできるようにすることを目的とした「スタートアップ」ダイアログです。

  1. このダイアログを開くには、ヘルプ: ラーニングセンターを選択するかF11キーを押します。
  2. Originが起動するたびにこのダイアログを表示または非表示にするには、開始時に表示チェックボックスをオンまたはオフにします。

ORG-14520-75PC.png


Origin 2023の新しいグラフ形式を確認するには、ラーニングセンターを開き、グラフサンプルタブをクリックして、フィルタドロップダウンですべてのプロットタイプ を選択し、2023 を検索します。

プロジェクトエクスプローラ

Origin 2023では、プロジェクトエクスプローラに新たな機能が追加されました。これらは、以下のフォルダとウィンドウについての2023での追加機能で説明しています。

プロジェクトエクスプローラ(PE)は、Originプロジェクトファイル(OPJ/OPJU)の内容を管理できる機能です。

PE window features2.png

プロジェクトエクスプローラは2つのパネルを持ちます。第一パネルではOPJのフォルダ構造を表示します。サブパネルには、メインパネルで強調表示されているフォルダに含まれるウィンドウが表示されます。


プロジェクトエクスプローラを使ってウィンドウを管理する

PE Preview on Hover.png
PE XLicons and tooltip3 600.png

Origin 2018以前のバージョンでは、PEのサブパネルは上パネルで選択されたフォルダ内のサブフォルダを一覧表示していました。表示モードを戻すには、システム変数@PEF = 1の設定をします。

PEフォルダ(上のパネル)を右クリックしてコピーを選択するか、またはフォルダを選択してCTRL+CとCTRL+Vを実行して、現在のプロジェクト内の別のフォルダ、または(b)2番目のOriginセッションで実行中の別のプロジェクトにフォルダ構造と内容をコピーして貼り付けます。単一のワークブックウィンドウをコピーするには、ウィンドウ(下パネル)を右クリックしてコピーしてから(a)同じプロジェクト内の別のフォルダ、または(b)2番目のOriginセッションで実行中の新しいプロジェクトに貼り付けます。

  1. ヘルプ: フォルダを開く: プログラムデータフォルダを選択して、Samplesサブフォルダをクックし、Tutorial Data.opjをOriginワークスぺースにドラッグします。
  2. デフォルトで、プロジェクトエクスプローラはワークスペースの左側にドッキングされ、自動で非表示になっています。プロジェクトエクスプローラタブ上にマウスを移動すると、ウィンドウが開きます。
    PE tab mouseover.png
  3. プロジェクトエクスプローラのタイトルバー上にある画鋲のアイコンをクリックして、このウィンドウを指定の位置にドッキングします。
    PE tab pushpin.png
  4. デフォルトでサブパネルは詳細表示になっています。この表示では、名前サイズコメント、といったウィンドウのメタデータが表示されます。列ヘッダをドラッグして、順序を変更してみましょう。
    PE headings.png
  5. 列ヘッダで右クリックしてそれぞれの項目のチェックによって、表示/非表示を切り替えできます。
    PE hide show headers.png
  6. コメント欄でコメントを追加するには、一度クリックし、もう一度クリックします。これにより編集モードになります。コメントを入力します。
    PE add comments.png
  7. ウィンドウの名前を変更するには、行で右クリックして名前の変更を選択します。名前欄ではデフォルトでウィンドウのショートネーム、ロングネームが存在する場合はロングネームを表示します。(全てのウィンドウはショートネームを持ち、ロングネームはオプションです)。編集可能な名前フィールドの右側にあるSNまたはLNボタンをクリックして、ショートネームまたはロングネームを編集します。ロングネームがない場合、入力できます。
    PE rename.png
  8. プロジェクトエクスプローラの上部パネルで、3D Surface with Point Labelフォルダにスクロールし、クリックします。サブパネルはフォルダ内の3つのウィンドウを表示します。ワークシートウィンドウeastcali3053は太字で表示され、アクティブなウィンドウであることを示します。アクティブウィンドウは操作されているウィンドウで、使用可能な操作を決定します。また、ノートウィンドウとMBook4行列ウィンドウがあります。
    PE active window.png
  9. サブパネルでMBook4をダブルクリックすると、太字表示になり、アクティブウィンドウである"halo"が表示されます。ウィンドウ全体(ワークスペース内)には、システム変数 -@AWCで色をカスタマイズすることができるハローが表示されます。これは、これが「アクティブ」ウィンドウであることを示す別のインジケータです。MBook4アイコンを再度ダブルクリックすると、アイコンが淡色表示になります。ワークスペースから実際のウィンドウがなくなります。これはMBook4が非表示になったためです。MBook4を再度ダブルクリックすると、ウィンドウが復元され、アクティブになります。
    PE window hidden.png
  10. MBook4をアクティブにして、作図> 3D: 曲面: 3カラーマップ曲面をクリックします。これで3Dカラーマップ曲面を作成できます(確認メッセージは閉じます)。新しいウィンドウGraph1がプロジェクトエクスプローラのサブパネルに表示されます。
  11. サブパネルの何もない部分を右クリックして、表示モード: より大きいアイコンを使用を選択します。Graph1がサムネイル表示になります。
    PE XLarge Icons.png
  12. また右クリックして表示モード: 大きいアイコンを選びます。ウィンドウはアイコンで表されるようになりますが、アイコン上にマウスを置くと、ウィンドウの内容がポップアップとして表示されます。
    PE large icon popup.png

PEのプレビューを無効にする場合、スクリプトウィンドウ(ウィンドウ:スクリプトウィンドウ)を開き、次のいずれかまたは両方を入力してから、テキストを選択状態にしてEnterキーを押します。

@PESS=-1; // PEでウィンドウプレビューをオフ、ウィンドウコメントをツールチップとして表示 @PESH=0; //ウィンドウコメントツールチップをオフ

スクリプトウィンドウを使ってシステム変数の値を設定した場合、現在のセッションに対してのみOrigin の動作が変更されます。異なるセッションでのシステム変数の値を設定するには、このFAQを参照してください。

フォルダとウィンドウについての2023での追加機能

フォルダノート

Origin 2023では、プロジェクトエクスプローラフォルダにフォルダノートを追加できます。

  1. フォルダ上で右クリックしてフォルダノートを選択します。


加えて...

UG PE toolbar 2023.png
フォルダとウィンドウツールバー

Origin 2023では新しいフォルダとウィンドウツールバーが追加されました。このツールバーを使用すると、プロジェクトエクスプローラ (PE) のフォルダを簡単に切り替えたり (シーソー/Seesaw)、アクティブなウィンドウを前のフォルダにショートカットとして追加したりできます。さらに、アクティブなウィンドウを所定の位置に固定したり、アクティブなフォルダ内のウィンドウを整列(ウィンドウ:ウィンドウの整列<前回どおり>)が可能です。

UG folders windows toolbar.png
  • 前のフォルダ: 現在のフォルダから一つ前のフォルダに戻ります。
  • 次のフォルダ: 前のフォルダから現在のフォルダに戻ります。
  • Seesaw: 2つのフォルダを交互に切り替えます(Ctrl + Alt + X)。メニューではウィンドウ: シーソーを選択します。
  • シーソー用にアクティブウィンドウのショートカットを追加: アクティブウィンドウを前のフォルダにショートカットとして共有します(Ctrl + Shift +F7)。 他の方法として、ウィンドウタイトルを右クリックして、前のフォルダにショートかとを追加できます。
  • 前のフォルダからショートカットを追加: ウィンドウの種類によって現在のフォルダにショートカットを追加します。
  • ウィンドウを整列 (前回どおり): ウィンドウ: ウィンドウを整列<前回どおり>メニューと同じです。
  • アクティブウィンドウを固定: ウィンドウを固定して、ウィンドウを整列(前回どおり)をクリックしたときに除外します。他の方法として、ウィンドウタイトルを右クリックしてウィンドウを固定(固定解除)できます。
ウィンドウショートカット

プロジェクトエクスプローラで選択されているフォルダとは別のフォルダにカーソルを合わせ、右クリックすると、現在のフォルダにショートカット追加が可能です。ウィンドウタイプ別にアクティブフォルダにショートカットを追加するためのダイアログが開きます。

UG add shortcuts to active folder dialog.png

アプリセンターとアプリギャラリー

アプリは、特別なグラフ作成や分析タスクを行うためのアドオンアプリケーションです。科学技術分野で広く適用されるいくつかのアプリは、Originソフトウェアに事前インストールされています。
LaTeX apps gallery.png

アプリセンターダイアログを利用して、Originアプリを検索したりアップデートやダウンロードを行えます。この新しいダイアログでは、ブラウザを開くことなく、OriginLabのファイル交換の場のすべてのアプリケーションに直接アクセスできます。
Interface App Central.png

プリセンターを開くには、Originのワークスペース右側にあるアプリギャラリー内のアプリの追加ボタンをクリックします。アプリギャラリーがないときは、表示: アプリ(またはALT + 9)をクリックして、アプリの横にチェックマークがあることを確認します。

Originの統計解析: フィット解析: ピークと基線メニューには、アプリ検索メニューが含まれます。アプリ検索をクリックすると、アプリセンターが開き、統計などのメニューに関連するアプリのみを表示します。アプリセンターから直接アプリのダウンロードや更新か可能です。

アプリギャラリーを使ってインストール済みのアプリにアクセスしたり管理できます。

アプリの新しい/更新バージョンは、OriginおよびOriginProユーザーが継続的に利用できます。F10キーを押してアプリセンターを開いてください。赤い今すぐダウンロードボタンが表示されている場合は、クリックして利用可能なアプリの最新リストを取得してください。

Check Apps Update.png

アプリについての詳細は、www.originlab.com/appsを参照してください。

オブジェクトマネージャ

オブジェクトマネージャは、ワークスペースの右側に開く、デフォルトで接続可能なパネルです。オブジェクトマネージャを使ってアクティブグラフまたはワークブックウィンドウに対して素早い操作が可能です。


グラフウィンドウ

Object manager highlight.png
UG OM objects vs plots.png
Object manager hide element.png


ワークブックと行列ウィンドウ

オブジェクトマネージャは、ワークブックと行列における特定の操作もサポートしています。


UG UI OM workbook.png


レイアウトウィンドウ

レイアウトページがアクティブなとき、オブジェクトマネージャのショートカットメニューコマンドをつかってオブジェクトを一覧表示し、配置できます。

Originの子ウィンドウ

アクティブウィンドウ(グラフや解析が実行されるウィンドウ)はアクティブなことを明瞭に示すために、色付きの枠で囲みます。@システム変数 @AWC(color)と@AWI(style)を使用して、アクティブなウィンドウインジケータのプロパティ(フレームの色、フレームのフレームスタイルを示すフレームラインスタイル)をカスタマイズできます。

Active window halo.png
KaTeX Notes window.png
Note: 子ウィンドウについての詳細は、以下を参照してください。

ヘルプ:Origin:Originヘルプ > Originの基本 > Originのワークスペース > 子ウィンドウ の作成

ヘルプ:Origin:Originヘルプ > Originの基本 > Originのワークスペース > 子ウィンドウの基本操作



Originプロジェクトファイルとは独立してOriginの子ウィンドウを保存するには:


Note:外部のExcelファイルとしてExcelウィンドウを保存するには、Origin内でExcelウィンドウタイトルを右クリックして、コンテキストメニューからワークブックの新規保存...を選択します。

Origin 2023では、ウィンドウの新規保存ダイアログのファイルパスドロップダウンに便利なオプションが追加されています。

UG save window as path.png

Origin 2018 でUnicode (UTF-8)対応のOriginプロジェクト、子ウィンドウ、テンプレートを追加しました。ウィンドウファイルを保存する場合、Origin 2023 の時点でUnicode準拠 (*.opju) としてのみ保存できるプロジェクトファイルを除き、ファイルタイプに" u " が追加されます (*.otp または *.otpu)。最新バージョンのOriginでのみファイルを使用する場合は、パフォーマンス上のメリットがあるため、Unicode(u付きのファイル形式)オプションを選択します。


ファイルに保存したワークシート、グラフ、行列、ノートウィンドウを開くには、

Note: Originでは、ウィンドウショートネームロングネームコメントをサポートしており、ショートネームはOriginプロジェクトで一意である必要があります。ウィンドウショートネームが、すでに使われている名前であれば、名前を付け直します。現プロジェクトでウィンドウファイルを開き、プロジェクトを保存すると、ウィンドウはプロジェクトに含まれます。


Excelワークブックファイルを開くには

OriginでExcelファイルを操作する場合は、あらかじめ、Originヘルプファイルのこのセクションをご確認ください。

Note: Excelを開くを選択すると、Originの内部でExcelのセッションが起動して、Excelファイルが開きます。このモードで使用できるOriginの機能は限られます。データ:ファイルに接続:Excelまたはデータ:ファイルからインポート:Excelを選択した場合、Excelファイルは、Originのワークブックにインポートされるので、Originの全ての機能を使用することができます。

子ウィンドウの整列

子ウィンドウを重ねて並べる上下/左右に並べるといった基本的な配置操作以外にもウィンドウを整列する機能があります。高解像度モニタを使って多くのウィンドウを使用して作業しているようなユーザには役に立つツールです。

Origin 2023では、子ウィンドウの配置機能がいくつか改善されました。

  • ウィンドウを整列ダイアログに、最小化ウィンドウを含めるチェックボックスを追加しました。
  • 新しいフォルダとウィンドウツールバーには、 アクティブウィンドウを固定ボタンがあり、ウィンドウをメニューまたはツールバーボタンで整列するときに、除外するために使用されます。このボタンをクリックするとウィンドウタイトルバーにボタンUG Notes pin button.pngが追加されます。また、ウィンドウタイトルバーを右クリックし、ショートカットメニューからウィンドウを固定を選択します。
  • 場合によっては、ウィンドウを配置した後で、見やすくするためにウィンドウを拡大することがあります。ウィンドウ: ウィンドウ サイズを復元 (Ctrl + Shift + Z) を選択すると、ウィンドウを以前のサイズと位置に戻せます。
ウィンドウを整列ダイアログ

この機能の中心となるのは、メインメニューのウィンドウ:ウィンドウを整列を選択して開くウィンドウを整列(winarrange)ダイアログです。

UG winarrange dlg.png

このダイアログを使ってOriginのワークスペース内の子ウィンドウをソートしたり、配置することができます。

ウィンドウのスナップ

行と列で整列されたウィンドウは「スナップ」できます。これにより、あるウィンドウの端をドラッグすることで同じ行または列にあるウィンドウサイズを変更できます。スナップする際には緑色のバーが表示されます。

  1. ウィンドウ:ウィンドウのスナップ(Ctrl + F12)を使用して、この機能のオフとオンを切り替えできます。
UG snap green bar.png


コマンドウィンドウとスクリプトウィンドウ

コマンド ウィンドウを使用して、LabTalkコマンドを Originで実行したり、簡単な数学的計算や、LabTalk変数の値を確認が可能です。コマンドウィンドウには、あるセッションから別のセッションに持ち越すことができる、タイムスタンプ付コマンド履歴と、Xファンクションコマンドを入力する際に自動修正機能があるインテリセンスが組み込まれています。

コマンドウィンドウは、ドッキング可能なウィンドウで、2つのパネルがあります。左側パネルにコマンド履歴が表示され、右側パネルにはコマンドラインがあります。

スクリプトウィンドウには、コマンドウィンドウと同じ機能があります。コマンドウィンドウの機能の一部(インテリセンス、コマンドプロンプト、コマンド履歴なし)がありませんが、単純なLabTalkコマンドの実行(LabTalkシステム変数の値の変更など)には便利です。ウィンドウのツールメニューで、Originの変数、関数、マクロ、ルースデータセットのリストを表示可能なLabTalk変数と関数ダイアログボックスを開くこともできます。


コマンドウィンドウを開くには


スクリプトウィンドウ開くには、

数式バー

数式バーは、OpenOfficeやExcelのものと同じように使うことが出来ます。数式バーを使用してセル式を入力する必要はありませんが、関数検索、インタラクティブな範囲選択、および式、特にセル幅を超える長い式の見やすさの向上という利点があります。

UG Formula Bar UI.png
  1. ワークブックがアクティブな状態で、メインメニューの表示:数式バーをクリックして、数式バーの表示と非表示を切り替えます。
  2. フォントサイズを変更するには、 LabTalkシステム変数の値を変更します @FBFS (デフォルトでは「130」です)。


より詳細な情報は、ワークブック、ワークシート、列の章を参照してください。

  • 値の設定ダイアログなどの関数メニューから開ける関数の検索ダイアログが、メインメニューのツール:関数の検索を選択することで直接開けるようになりました。

ステータスバー

The Status Bar-1.png

ステータスバーは、Originワークスペースの下部にあります。以下のようなパラメーターを表示します。


ステータスバーデータの設定とコピー

スマートヒントとスマートヒントログ

スマートヒントは、ユーザー行った操作に関するヘルプを提供するものです。これらのヒントは次の例のようにダイアログの中で、短い時間表示されることがあります。

Smart Hint1.png



または、下の例のように、Origin ワークスペースの左下にスマートヒントが表示される場合があります。

Smart Hint2.png


ヒントにカーソルを合わせないと、すぐに非表示になります。スマートヒントログの下部にある「次回からメッセージを出さない」ボックスにチェックを付けると、各ヒントの表示を消すことができます。

現在のOriginセッションのヒントはログとして保存されているので、Originのワークスペースの端にドッキングされていスマートヒントログタブをクリックすると表示できます。(注意:ダイアログ内のヒントは、ログが残りません。)

Smart Hint3.png


スマートヒントログウィンドウを開く(閉じる)には次の操作を行います。

  1. メニューから表示:スマートヒントログを選択するか、ALT+7を押します。

現在のセッション内で特定のヒントを非表示にするには、スマートヒントログウィンドウ内のヒント上で右クリックして、コンテキストメニューからこのヒントは再度表示しないを選択してチェックを入れます。このメッセージを表示または記録しないことを確認するメッセージが表示されます。

スマートヒントの表示をオフにするには、スクリプトウィンドウを開き、以下のコマンドを実行します。

@SHS = 0;

個別に非表示に設定したものを含め、スマートヒントを表示させるには、システム変数@SHS = 1 にセットし、メニューからヘルプ:全てのヒントの復活

スクリプトウィンドウを使ってシステム変数の値を設定した場合、現在のセッションに対してのみOrigin の動作が変更されます。異なるセッションでのシステム変数の値を設定するには、このFAQを参照してください。

コードビルダ

Origin Cの統合開発環境 (IDE)をコードビルダといいます。コードビルダは、Origin Cのプログラムを記述したり、コンパイルしたり、デバッグするためのツールを提供します。さらに、Pythonコードの実行とデバッグに使用できます。

コードビルダを開くには

  1. Originメニューから、表示:コードビルダを選択するか、標準ツールバーのコードビルダボタンButton Code Builder.pngをクリックするか、ALT + 4を押します。
  2. コードビルダは、接続:新規untitled.pyをクリックして開くこともできます。このモードでは、CTRL + F5を押して、Pythonコードを貼り付けて実行できます。

メッセージログ

メッセージログは動作に関するメッセージ(出力、結果、エラーを含む)を表示します。スクリプトウィンドウコマンドウィンドウに表示されないメッセージを表示します。


メッセージウィンドウを開く(閉じる)には次の操作を行います。

  1. メニューから表示:メッセージログを選択するか、ALT+6を押します。

Origin 2023から、エクスポートダイアログ (画像内の箇条書きリストを参照) で出力すると、メッセージログに日時スタンプ付きでリンクを追加します。リンクをクリックして、デフォルトのアプリケーション (*.datの場合メモ帳など) でファイルを開きます。

UG Message Log Link.png
  • ファイルを開かずにWindowsエクスプローラーでファイルの場所を開くには、リンクを右クリックしてファイルの場所を開くを選択するか、Ctrlキーを押しながらリンクをクリックします。
  • 2つのシステム変数を使ってこの画像エクスポートリンクの動作を制御できます。詳細は、画像ファイルへのグラフやレイアウトページのエクスポートを参照してください。

結果ログ

Origin は、多くの分析結果とフィット結果を結果ログに自動的に表示します。結果ログの各エントリには、日付/時刻スタンプ、ウィンドウ名、ユリウス日 (以下の日付を参照) である数値スタンプ、実行された分析の種類、および結果が含まれます。

通常、結果が結果ログに出力されると、結果ログが自動的に開きます。次のいずれかを実行して、手動で結果ログを開きます (または閉じます)。

  1. 標準ツールバーの結果ログボタンButton Results Log.pngをクリックします。あるいは、メニューから表示:結果ログを選択するか、ALT+2を押します。


結果ログの内部で右クリックすると、 コピー印刷クリア結果表示が可能です。

ウィンドウのフロート/ドッキングと自動非表示

フローティング、ドッキング、自動非表示、非表示といったOriginのウィンドウがいくつかあります。これらのウィンドウは、 プロジェクトエクスプローラ結果ログコマンドウィンドウメッセージログを含みます。これにより、Originワークスペースをカスタマイズして、作業スペースを最大化し、画面スペースを節約できます。

数値の扱いについて

Note: 数値の詳細は、以下を参照してください。

ヘルプ:Origin:Origin ヘルプ > Originの基本 > Originのワークスペース > 数値の扱いについて


Originのワークブックと行列ブックは、次のデータ型をサポートしています。

ワークブック 行列ブック Byte 値の範囲

double

double

8

±1.7E±308 (15ケタ)

real

float

4

±3.4E±38 (7ケタ)

short

short

2

-32,768から32,767

long

int

4

-2,147,483,648から2,147,483,647

char

char

1

-128から127

byte

char, unsigned

1

0 から 255

ushort

short, unsigned

2

0から65,535

ulong

int, unsigned

4

0から4,294,967,295

complex

complex

16

±1.7E±308 (15桁)、それぞれ8バイト

参考