ガジェット

ガジェットを使用すると、データプロットを素早く簡単に分析することできます。ガジェットの概念は単純です。それぞれのガジェットには、特定の目的があります。カスタマイズできる分析操作を、関心範囲(ROI)オブジェクトで定義されるプロットデータ範囲に適用します。このオブジェクトは、移動、サイズ変更可能です。

いつでもドラッグで、ROIを変更することができます。そして、ROIの右上の角にある矢印ボタンをクリックし、メニューオプションを選択することによって、分析オプションを変更したり、結果の再計算が可能です。通常、ガジェットの形式と分析オプションにアクセスするには、ガジェットコンテキストメニューの下にある設定を選択します。 ダイアログテーマを使い、テーマファイルにガジェット設定を保存できます。

グラフ上で複数のガジェットの使用がサポートされています。それぞれ異なる色によってROIが区別されます。ROIオブジェクトをクリックして、選択します。ROIが選択されている時、TABキーを押してROIを切り替えられます。

Grand image gadgets 2c.png

Origin 2016からアドオンツールのアプリが利用可能になりました。OriginLabのファイル交換の場に追加された新しい拡充したツール、および、さらに新たなツールがいつでも利用可能です。ファイル交換の場を開き、利用可能なツールをご覧ください。

Originのガジェット

ガジェットは、グラフがアクティブな時にガジェットメニューからアクセスできます。以下がOriginが提供する14個のガジェット機能です:

クラスターガジェット グラフィカルに定義された関心領域(長方形、円形/楕円形、または任意の形状)の内側または外側のポイントに関する統計を表示します。 OriginPro Symbol.png
微分ガジェット 選択されたデータの微分階級の微分曲線を素早く表示します。
FFT ROIツールガジェット グラフ上の信号データにFFTを実行します。
積分ガジェット 曲線以下の面積や曲線間の面積を計算します。
2D積分ガジェット 行列やXYZワークシートデータから作図された等高線図やイメージグラフで2D積分を実行します OriginPro Symbol.png
補間ガジェット 選択されたデータに対し、線形、スプライン、Bスプライン、 Akimaスプラインで補間を実行します。
交差ガジェット 2つ以上のデータプロットの交点を算出します。
クイックフィットガジェット 選択されたデータに対し、線形、多項式、非線形フィットを実行します。

Origin 2022bでは、クイックフィットガジェットROIボックスのラベルをカスタイマイズできます。

クイックピークガジェット ピークを検出し、面積等のピーク情報を算出します。
クイックシグモイダルフィットガジェット 選されたデータに対しシグモイダルフィットを実行します。
立ち上がり時間パネルツール 階段状信号の立ち上がり/立ち下がり時間を解析します。 OriginPro Symbol.png
統計ガジェット 選択された領域内の基本統計情報を取得します。
垂直カーソルガジェット 同じX軸を共有する複数のグラフレイヤにわたって座標値を読み取り、データプロットにラベルを付けます。
イメージ/等高線プロファイル 行列データから作成されたイメージプロットや等高線図を分析し、プロファイルを生成します。
曲線移動ガジェット 曲線を垂直または水平方向にドラッグして、ソースデータを調整します。
Note: ガジェット機能についての詳細は次のヘルプファイルを参照してください。

ヘルプ: Origin: Originヘルプ >ガジェット

ヘルプ: Origin: Origin ヘルプ >行列ブック、行列シート、行列オブジェクト > 行列データの表示とプロファイル

チュートリアル:積分ガジェットを使用し、解析結果をワークシートに出力する

  1. 新しいワークブックを作成し、OriginのインストールフォルダにあるSamples\Spectroscopy 内のPeaks on Exponential Baseline.dat をインポートします。
  2. B列から折れ線図を作図します。
  3. グラフをアクティブにして、メインメニューから、ガジェット:積分を選択します。
  4. ダイアログボックスが開いたら、基線タブをクリックして、モード直線に変更します。
  5. 出力タブをクリックして、出力先ノードにあるワークシートに追加にチェックを付け、他のチェックボックスについているチェックは外します。
  6. 計算する値ノードを開き、データセット識別子なしにしてX開始X終了のチェックを付けます。
  7. OKをクリックしてダイアログボックスを閉じます。ROI(region-of-interest、関心領域)ボックスがグラフに追加されます。
  8. 一つ目のピークを囲むようにROIボックスの位置とサイズを変更します。ROIボックスの右上にある矢印ボタンRight arrow menu button.pngをクリックしてフライアウトメニューから新しい出力を選択します。またはキーボードの「O」を押します。この操作により、結果ワークシートに一つ目のピークパラメータが出力されます。
  9. ROIボックスをドラッグして移動し、二つ目のピークを囲います。上記の操作と同様に、二つ目のピークパラメータを出力します。
  10. 矢印ボタンRight arrow menu button.pngを再度クリックしてレポートシートに行くを選択します。すると、積分結果が出力されたワークシートが開きます。

GSB Gadget Tutorial.png

ROIボックスの右上にある、フライアウトメニューボタンRight arrow menu button.pngをクリックして、表示されるコンテキストメニューで、現在のレイヤ内の全ての曲線に対する結果出力(全てのカーブ(N)に対する新しい出力)や、グラフページの全てのレイヤに対する結果出力(全てのレイヤ(L)に対する新しい出力)することができます。また、対応するNLホットキーを押すことでも可能です。これにより、グラフ内の複数曲線に対するバッチ解析が可能です。

ROIボックスのカスタムラベル

Origin 2022bは、クイックフィットおよび統計ガジェットで表示されるROIボックスのラベルをカスタマイズできます。

UG stats gadget custom label.png

クイックフィットガジェット

  1. メニューからガジェット:クイックフィットを選択します。
  2. ガジェットダイアログが開きます。ROIが追加された場合、Right arrow menu button.pngボタンをクリックして、設定を選択します。
  3. ROIボックスタブを開き、カスタムラベルにチェックを付けます。
  4. (a) リテラルテキスト、(b) エスケープシーケンス(ギリシャ文字の記号や上付き文字など)、(c)カスタム変数を組み合わせてカスタムラベルを作成します。Originのカスタムフォーマットを使用して小数点以下の桁数などを指定します。
ダイアログでの名称 カスタム変数 サンプル
補正R二乗 chisqr Chi-Square \g(c)\+(2) = $(chisqr, .2)
R二乗 cod R-Squared r\+(2) = $(cod, .2)
ピアソンのr r r = $(r, .2)
Y切片 intercept Y Intercept = $(intercept, .2)
傾き slope Slope = $(slope, .2)
X切片 xintercept X Intercept = $(xintercept, .2)

統計ガジェット

  1. ガジェット:統計:ダイアログを開くを選択します。ROIが追加された場合、Right arrow menu button.pngボタンをクリックして、設定を選択します。
  2. ROIボックスの上中央に表示タブを開き、カスタムラベルにチェックを付けます。
  3. (a) リテラルテキスト、(b) エスケープシーケンス(ギリシャ文字の記号や上付き文字など)、(c)カスタム変数を組み合わせてカスタムラベルを作成します。Originのカスタムフォーマットを使用して小数点以下の桁数などを指定します。
ダイアログでの名称 カスタム変数 サンプル
N n Count = $(n)
平均 mean \g(m) = $(mean, *4)
最小 min Min = $(min, .2)
最小のX xminy X Min = $(xminy, .2)
最大 max Max = $(max, .2)
最大のX xmaxy X max = $(xmaxy), .2)
合計 sum Sum = $(sum, .2)

参考