31 Appendix 5 - Notable Changes for Older Version Users

When upgrading from an older version of Origin to the latest version, you may need to review the following key changes to Origin that happened over the past many versions, to adjust your workflow accordingly.

Worksheet Column Names

Version when this was changed: Origin 2017(9.4)

Naming of column short names in worksheets was changed to be fixed by default as A, B, C.... similar to Excel. This change was made to simplify writing of column formula. When columns are moved around, the names adjust to maintain the alphabetic order from left to right, and existing column formulae are automatically updated.

This new notation is referred to as Spreadsheet Cell Notation (SCN). It is a property of the worksheet and can be turned off if you desire, although we recommend that you use the column Long Name for descriptive names instead of the Short Name property.

If you open old projects or workbooks that had column short names set to specific names, then the SCN property is automatically turned off when you open in the latest version. If you turn the property on, then you will lose the short names that were assigned.

For more information, refer to this FAQ on SCN.

File Import

Version when this was changed: Origin 2019b(9.65)

The Data Connector mechanism for connecting to local and web files was introduced in Origin 2019b. A new Data menu was also introduced. The old import routines are still available under the Data menu, but we recommend using the Data Connectors.

The imported data is locked, by default, from editing when using Data Connectors. Data above a pre-set size are also cleared by default when the project is saved, to maintain smaller project file size.

For more information, refer to this Data Connector page.

Project File

Version when this was changed: Origin 2018(9.5)

Origin 2018b introduced a new Unicode based OPJU file format for saving Project files. Older files with extension OPJ can be opened in the recent versions. The File> Save As... dialog also allows saving projects to the older OPJ format. The system variable @OPJ can be used to control the default format for saving projects.

64 vs 32-bit

Version when this was changed: Origin 2020(9.7)

Origin 2019b was the last version to support 32-bit. From Origin 2020 onward, Origin software is only offered in 64-bit versions.

Custom Menus

Version when this was changed: Origin 2020(9.7)

The Short Menus option has been removed from the GUI and is only available by setting @SCNFM=1. However, if there are any custom menus, short menus will not work properly.

CNF file-based custom menus still work properly but have been supplanted by the Custom Menu Organizer (OMC file-based). Once the Custom Menu Organizer has been run, previously created CNF file-based menus will be disabled as you cannot have CNF menus and OMC menus. To reinstate CNF file-based menus, Edit origin.ini (in the User Files folder) and add the following:

[Config]
MenuLevelByOMC=0

Auto Loading Origin C Files

Version when this was changed: Origin 2015(9.3)

Staring with Origin 2015, you cannot add user Origin C files to the System folder in Code Builder. You now add them to the Autoload folder. Files in the Autoload folder will be automatically compiled during Origin startup. Also during Origin startup, if user files are detected in the System folder, they will be automatically moved to the Autoload folder and the user will be notified. For more information about this subject see: Add Files to the User [AutoLoad] Folder